Inconsistency between the local app and the remote build

I'm having an issue with building my Xamarin project in VS2017. I've always built it in Xamarin Studio in the past, but wanted to give Visual Studio a try.

Whenever I try to run, I get

An inconsistency between the local app and the remote build has been detected for <app>. Please rebuild the application and try again. Check the log for more details

I have is that I don't know where this magical log is, because the error message provided is completely useless. So I'm not sure what route to even go down debugging this issue.

I happened across this bug from about a year ago https://bugzilla.xamarin.com/show_bug.cgi?id=36059

One possible problem mentioned is the connection between mac and windows being closed, but this is not the case either. I've tried disconnecting and reconnecting, and nothing changes.

The bug previous bug report says that the problem is the signatures mismatching between the windows obj folder, and the xamarin cache obj folder on the mac agent.
I checked the signatures manually, and the signatures for my executable project match on the windows and mac side. However, in the windows side there's a signature and signature-remote file. The signature file matches the mac signature file, and the signature-remote file is empty. This seems to indicate to me that something is going wrong recovering the signature from my mac to be able to compare them, but I have no way of confirming that.

Does anyone know how to either debug this problem, or get it fixed?

Best Answer

Answers

  • Daniel.1965Daniel.1965 USMember

    Thanks for the input. I've tried doing a clean in vs, and verified that all obj and bin folders are removed, and deleting the contents of ~/Library/Caches/Xamarin/build/mtbs/builds/ but with no luck

  • Daniel.1965Daniel.1965 USMember

    I tried the clean again, and it decided to work today. Thanks!

  • EddieMEddieM USMember ✭✭

    I have the same issue. Removing all files from obj, bin does not work. When removing files from the cache on the Mac I get another error about the signature file not existing. Any other solutions?

  • johanksonjohankson SEInsider, University ✭✭

    Clean, restart VS, rebuild works for me 5 times out of 8,5.

Sign In or Register to comment.