Svn not working on latest version of XS 6.2

OnurHazarOnurHazar USUniversity ✭✭✭


After updating XS on mac, I am having issues on managing my svn repos through XS. Now, XS says they are not under version control. Svn version is 1.9.4. My working copies are already upgraded since the previous update of Xamarin and they were all working. Please help!

Xamarin Studio Community
Version 6.2 (build 1821)
Installation UUID: 3e137f12-4510-4e3a-b13e-63bc3fac9a8c
Mono 4.8.0 (mono-4.8.0-branch/e4a3cf3) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 408000495


Version: 1.0.0
Location: /Applications/Xamarin Profiler

Apple Developer Tools
Xcode 8.2.1 (11766.1)
Build 8C1002

Version: (Xamarin Studio Community)

Version: (Xamarin Studio Community)
Android SDK: /Users/onur.hazar/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
4.4 (API level 19)
5.1 (API level 22)
6.0 (API level 23)
7.0 (API level 24)
7.1 (API level 25)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.3
SDK Build Tools Version: 25.0.2

Java SDK: /usr
java version "1.8.0_45"
Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

Android Designer EPL code available here:

Xamarin Android Player
Not Installed

Xamarin Inspector
Hash: 607f1ba
Branch: 1.1-release
Build date: Thu, 16 Feb 2017 18:57:39 GMT

Version: (Xamarin Studio Community)
Hash: 35d1ccd
Branch: cycle9
Build date: 2017-02-16 17:40:00-0500

Build Information
Release ID: 602001821
Git revision: d41b6e51f3fa46a1943f2e31a778d28a7c73d069
Build date: 2017-02-17 15:18:19-05
Xamarin addins: 1363a8d943bab7700c93a97474060b6734aa7f94
Build lane: monodevelop-lion-cycle9

Operating System
Mac OS X 10.11.6
Darwin adb-macmini01.local 15.6.0 Darwin Kernel Version 15.6.0
Thu Sep 1 15:01:16 PDT 2016
root:xnu-3248.60.11~2/RELEASE_X86_64 x86_64

Enabled user installed addins
MvvmCross Template pack 1.2.6
XamlStyler 1.0.3


  • Same issue for me too.

  • OnurHazarOnurHazar USUniversity ✭✭✭

    I ended up the issue by downgrading Xamarin and checking out the repo with old svn client 1.7.

    I also create a bug report here;

  • ErnestJErnestJ AUMember ✭✭✭

    Thank you for this solution, we just switched to community version and I thought it had the issue with version control, but looks like it was latest Xamarin update (as usual).

  • MarcoPiralliMarcoPiralli ITMember

    Any news about the issue in the latest version of XS (6.2). There are fixes or a workaround that is not the downgrade?

  • ZmasterZmaster USMember ✭✭

    Same problem. Quite annoying.
    I can't see the status on that ticket because it says I'm not authorised.

  • KeskinOnurKeskinOnur USMember ✭✭

    Same here, any news?

  • ChrisBoehmChrisBoehm USUniversity ✭✭

    I'm experiencing this issue also in XS 6.2. I upgraded two machines to 6.2 and both experience this issue. I also have the latest XCode and command-line tools installed.

  • IuliaJecanIuliaJecan USMember ✭✭

    I have the same problem. Did someone found a solution for this? Not a fan o downgrading :(

  • lex3rlex3r USMember ✭✭

    Same issue. Any soultion ?

  • magic67magic67 USMember ✭✭✭

    Same problem here with 6.2 (build 1821) - I've succesfully rolled back to 6.1.5(build 0)

    No acknowlegement or work arounds forth coming?

    Does build 1829 fix the issue. I don't feel like going through the update and roll back process again

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Updated Bugzilla cross-reference

    • Bug 53324 has now been filed to surface and track the information from non-public Bug 52840 in a public bug report.
  • magic67magic67 USMember ✭✭✭

    Just installed version 6.2(build 1821) on a new machine.
    Installed Mono 4.8.0
    Installed Xcode 8.2.1 and command line tools
    Java Development Kit 8u121

    Svn --version
    svn, version 1.9.4 (r1740329)
    compiled Nov 15 2016, 20:35:27 on x86_64-apple-darwin15.0.0

    Performed svn checkout from terminal, which works
    Performed svn info - works

    Opened solution file > Project is not under version control

    Go to Xamarin > Version Control > Checkout
    Only git is available to checkout

    Upgraded to build 1829, version control still not working - subversion still missing

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    @magic67 said:
    Upgraded to build 1829, version control still not working - subversion still missing

    That's why there's a bug filed to get it fixed.

  • magic67magic67 USMember ✭✭✭

    @DavidHunt said:
    That's why there's a bug filed to get it fixed.

    Bug 53324 has a NEEDINFO status on Comment 7. Which is why I was adding some of the steps I had performed on a new machine.

    I don't have authorisation to access Bug 52840.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    You could post those steps into bug 53324 directly. Eventually the private bug will be marked as a duplicate of the public bug when we get some more info from the reporter of 52840.

  • IanHoldstockIanHoldstock GBMember

    I've been caught by this issue as well, and I tried this: install the latest version of svn with homebrew (brew install svn). I got through the path issues, and now when I start up Xamarin studio the version control / checkout dialog has Subversion listed underneath Git. Hooray I thought. BUT Xamarin will now not open any projects - it crashes completely. The only way back to a working IDE was to uninstall the latest svn from brew.

    So the version of svn on my mac by default is 1.9.4 (installed from xcode command line tools), and brew installs 1.9.5_1 which is the very latest svn you can get.

    I do have a vague recollection of someone saying that svn 1.9.5_1 kills off Visual Studio in a similar way at project load time, anyone else heard of this?

    Anyway whilst it's not a solution, maybe the fact that subversion is reported by Xamarin when the latest version is installed might provide someone with a clue. I'm going back to using svn from the command line for the time being.

  • AdrianSalazarAdrianSalazar USMember ✭✭
    edited March 2017

    I have version 1.8.10 (r1615264) and works fine for me.

  • TilemahosBitsikasTilemahosBitsikas GRUniversity

    Maybe this bug's importance must be marked higher

  • ZmasterZmaster USMember ✭✭

    For people affected by this issue, the workaround is to create the symlink

    /var/db/xcode_select_link -> /Applications/

  • TobeTobe DEMember ✭✭

    For the Linux noobs like me, the command is "ln -s" and you have to enter the path to the symlink last, so its:

    ln -s "/Applications/" "/var/db/xcode_select_link"

    That took me a while, but it worked :smiley:

  • HoomanYazdi.4359HoomanYazdi.4359 USMember ✭✭

    Doesn't Xamarin want to fix this?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited May 2017

    Reminder Bugzilla cross-reference

    • Bug 53324 is the location where this issue is being tracked by the engineering team.

    (As noted in the earlier comment in this thread.)

  • intvsteveintvsteve USMember ✭✭

    @Zmaster and @Tobe - thanks much for this! This has also hit me. This is super helpful!

Sign In or Register to comment.