I am at a loss with Xamarin

Hi,

Almost every time that I have installed a "stable" update for Xamarin it has cost me countless hours in development attempting to fix some anomaly that it has created. Today, I installed the latest stable updates as there are a number of bugs in the Visual Studio interface that I had hoped would get fixed with the new release.

Upon installing it, I received an error "XamarinShellPackage" was not installed - here's a thread from 2015 about a similar issue: https://forums.xamarin.com/discussion/40197/xamarainshellpackage-did-not-load-correctly-in-vs-2015

I have tried repairing Xamarin, re-downloading 'Xamarin.VisualStudio_4.3.0.784.msi' and repairing/changing - get an error "Account already exists".

I tried repairing Visual Studio, and nothing resolves it.

Just now I opened my code solution and got a new error "XamarinIOSPackage" package did not load correctly.

When I open my code solution, the projects are sitting there saying "needs migration". When I try to reload them, I get told that " The application which this project type is based on was not found".

This is incredibly frustrating and I cannot come up with a solution to get Xamarin working again. Please advise.

Answers

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited February 2017

    @NormanBardell,

    We do have a known issue that can cause the "XamarinShellPackage" error. The quickest solution is to delete the Visual Studio MEF component cache directory at %LOCALAPPDATA%\Microsoft\VisualStudio\1*.0\ComponentModelCache.

    Replace the * with your version number.

    Also check in the VirtualStore directory to see if Windows might have stored any overlay files for the Extensions\Xamarin or ComponentModelCache directories there:

    %LOCALAPPDATA%\VirtualStore

    After those are deleted, start Visual Studio from the command line. To do this, open a Visual Studio Command Prompt (search in Windows 10 is the easiest way to open this quickly) and type

    devenv /ResetSkipPkgs

    This launches Visual Studio and instructs it to launch the previously failing Xamarin extension packages.

  • NormanBardellNormanBardell AUMember ✭✭

    @JohnMiller this doesn't resolve my issues unfortunately.

    I've deleted the ComponentModelCache folder and there's nothing related to Xamarin or ComponentModelCache. Regardless, I tried deleting what was there anyway.

    I loaded up VS with devenv /ResetSkipPkgs and it launches fine.

    When I go to Tools -> Xamarin to check that everything is fine, the errors pop up again:

    • 'XamarinShellPackage' did not load correctly.
    • 'XamarinIOSPackage' did not load correctly.
    • 'XamarinAndroidPackage' did not load correctly.

    I tried loading my project and it fails again.

    I've uploaded my ActivityLog.xml as a text file as the xml file was being rejected. Please advise what the next steps are.

  • NormanBardellNormanBardell AUMember ✭✭

    I've since tried every step here: https://developer.xamarin.com/guides/cross-platform/getting_started/visual_studio_with_xamarin/troubleshooting/uninstall-xamarinvs/

    And I still have had no success. I've logged in as a different user and the errors persist.

  • NormanBardellNormanBardell AUMember ✭✭

    Further to this, I've managed to rollback to Cycle 8 - 4.2.2.11 and it appears to be working OK. Unfortunately the reason I was upgrading to the next "stable" version was because there's many many bugs with the VS/Xamarin interface that I've noticed and was hoping they would be resolved in the new version.

    Can you please advise how to successfully upgrade?

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited February 2017

    @NormanBardell,

    @JimmyGarrido noticed that you were using VS 2012. Xamarin 4.3+ requires VS 2013 update 2 or newer, so that might explain why the extension is failing.

  • NormanBardellNormanBardell AUMember ✭✭

    @JohnMiller actually I'm using 2013. Where are you seeing 2012?

Sign In or Register to comment.