Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Using Xamarin.Android.Support.* 25.1.1?

fonix232fonix232 USMember ✭✭
edited February 2017 in Xamarin.Android

There's a project I'm working on, and it has an already working Android app with most of the BL in a separate BCL, using MvvmCross.

It used old Android.Support libraries (23.4.0) and the Google Play Services were outdated too (29.0.0.2). I got the task to update the libraries to the latest stable and most bug-free version, and add FCM support.

It wasn't a problem until I tried updating to 25.1.1. For some reason, the Xamarin plugin in Visual Studio refuses to load the proper repositories, and deleting everything in %APPDATA%/Local/Xamarin won't trigger an automatic download like it does with earlier versions (both 23.4.0 and 24.2.1 triggers the download during build). I tried to manually add them by downloading the latest r43 repository, and even created links to the extracted folder with the 25.1.1 version, but it still fails on building the PlayServices bits (e.g. there's Analytics built in, and Maps). The build system simply claims the specific XML references, method calls, etc. are all nonexistent, and fails. After adding the Support library bits manually, it finally went through these issues mostly, but the Play Services references still fail the compile.

Is there any way to manually trigger the download of these libraries? Adding the Nuget packages won't work - and the same happens on a Mac, using Xamarin Studio too.

Using the latest Release branch of Xamarin, but also tried on Beta.

Best Answer

  • fonix232fonix232 USMember ✭✭
    Accepted Answer

    Sorry for the late reply.

    I've upgraded to the latest, Cycle 9 release of Xamarin.VS, and the problem seems to be gone now.

Answers

Sign In or Register to comment.