Publish to Google Play not Incrementing Version Code

See Screenshot

Xamarin Studio for Mac (6.5.1 build 0)

Can't publish to Google Play. Build version is clearly "10", but whatever signifies the version code in the actual build itself is saying "9" as version code. Tried restarting, cleaning, rebuilding... all the standard stuff. Never gotten it to work.

AndroidManifest.xml clearly has:

android:versionCode="10"
android:versionName="1.0.10"

Am I the only one experiencing this? Any ideas?

Answers

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    This seems like a potential issue with the previous builds. Have you tried to manually upload the .apk to see if you get the same behavior? It might be a bug with the logic in the publisher here.

  • Hi Jon,

    Thanks for the reply! Uploading the APK manually through the google play dev console is the only way we've been able to publish so far. And even sometimes we have to archive it multiple times before the correct build number takes on the APK (we quite often get the same error even through google play). But we get an error 100% of the time when publishing through Xam Studio "A APK with version code (x) has already been uploaded".

  • AntonioFeregrinoAntonioFeregrino MXUniversity ✭✭

    I'm having this issue as well, I'm archiving using Xamarin Studio and manually uploading the .apk

    Even though Xamarin Studio shows the right version code, when I sign the app and try to upload it to google play, the developer console takes the package as if it had a previous version code, making me unable to update my app.

  • BrianKillenBrianKillen USMember ✭✭

    i also started to see this error today.

  • KaiWKaiW DEUniversity ✭✭
    edited February 2018

    @jasonshehane , @AntonioFeregrino , as you already had the problem 1 year ago I hope you already solved it. Do you have any tips, or did I just work again? I run into the same problems with my Xamarin Forms Android App currently, regardless whether I use Visual Studio (for Mac) publish to Play Store or the manually upload on the play store website :s

    Update: I just tried again on the website and now it worked...? It worked with the same version which did not work with VS publishing.... So I would be grateful for any tips as it seems the same problems might come up on the next version again....

Sign In or Register to comment.