Build failure for Android

johanksonjohankson SEInsider, University ✭✭
edited February 10 in Xamarin.Android

Hi!

Anyone that has any tips on how to fix this?

Tried

  • Deleting package folder
  • Delete all bin/obj folders
  • Updated Android SDK
  • Restarted computer
  • Sacrificed a goat

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. Perhaps it doesn't exist in the Mono for Android profile? File name: 'System.Drawing.dll' at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve (Mono.Cecil.AssemblyNameReference reference, Mono.Cecil.ReaderParameters parameters) [0x0015d] in <b6cbb86f53684354aa3ec27a22485825>:0 at Java.Interop.Tools.Cecil.DirectoryAssemblyResolver.Resolve (Mono.Cecil.AssemblyNameReference reference) [0x00001] in <b6cbb86f53684354aa3ec27a22485825>:0 at Xamarin.Android.Tasks.ResolveAssemblies.AddAssemblyReferences (System.Collections.Generic.ICollection`1[T] assemblies, Mono.Cecil.AssemblyDefinition assembly, System.Boolean topLevel) [0x00180] in <2fdd3551eb6c4960b69522c8a0cd7aa3>:0 at Xamarin.Android.Tasks.ResolveAssemblies.Execute () [0x001ec] in <2fdd3551eb6c4960b69522c8a0cd7aa3>:0 (CMW.Mobile.Droid)

// Johan

Tagged:

Answers

  • EugeneSM.0638EugeneSM.0638 USUniversity

    Up!
    Not a single answer in 8 months. Well, it does seem like there is not a single person on this planet who could really solve this problem.
    I've got the same story as in the post above. I googled about different ways to solve the issue, but whatever workarounds I tried - nothing works :s
    And still I badly need help with this(

    Thanks in advance!!!

  • rakeshraghavanrakeshraghavan INMember ✭✭
    What error you are getting?
  • CharlesKaimanCharlesKaiman USMember
    edited November 17

    Any solution? I run into this every year or so, and forget what I did to fix it. I will be sure to document it here if I figure it out.

    Occurs when trying to build Android. I feel like it had something to do with the Android SDKs not being up to date, but I updated them and that's fine. I also recall it could be something to do with the manifest, but couldn't find anything wrong there either. Grrrrrr...

Sign In or Register to comment.