Forum Xamarin.Android

Long, long quest to install VSC2015 and run the Xamarin app on emulator or device

Hi to All.
I installed Visual Studio Community 2015 to try Xamarin.
I got a bunch of troubles in my way to open a project and compile it.
I solved the issues by:

  • updated JDK from 1.7 to 1.8;
  • modified Android SDK path;
  • downloaded API 23 to get rid of compile error;

Now I can create, open and compile a simple android Xamarin project.
But I cannot run it on an emulator or on my device.
I use BlueStacks emulator. The app starts but shows nothing (any buttons, only black empty screen).
I tried create an emulator in the ADM. The app even didn't start.
I got 'Not installed' message on my device when tried to install it.
I 'played' with API versions, different options (Java Max Heap Size 1G, Use Shared Runtime, Use Fast Deploy, Linking etc).
LogCat shows a lot of messages (attached file). I don't see any to hint me (sorry, I'm newbie).

I used my PC (AMD Phenom CPU, Windows 7) and laptop (Intel iCore3, Windows 10).
Both failed.

So what can I do to run the app?
Is it possible to develop applications on VSC2015 Xamarin?
Thanks.

Sign In or Register to comment.