Remoted iOS Simulator - device not found

ruif90ruif90 PTMember ✭✭

For some reason, now I can't debug my application using Xamarin Simulator. Already tried to clear cache, clean, build, rebuild etc, I don't find any solution to fix this problem.

Anyone has any idea of might be wrong? I will share with you my log.

SSH Connect:
    target: MariaMac.local:4231
Using SSH pass phrase
SSH connected
Connection state changed:
    State: Connected
    Progress: 0
Connection state changed:
    State: CheckingServer
    Progress: 0
Connection state changed:
    State: Connecting
    Progress: 0
Connection state changed:
    State: Connected
    Progress: 0
Device not found:
    Requested: 5CAC8CBA-5E16-4BB7-919D-B9ECE723C679
    Devices: 8DE4D75A-482E-4C07-A0FF-4F14690EEC3B;863943E1-6EA7-43D4-B2FC-6502C48E8E87;AD9EFA87-5AD8-4676-AD89-F129D762D9AF;39BB751A-6222-48BE-828D-5505AFE76454;AD8DC89C-4B1C-4D95-843F-73642217A5C9;A11C48AE-CB96-4FB2-92E1-61F3EAC8AC1F;4EF7C728-3658-4C6E-B1B2-671652FDE3CE;A3423465-2C0B-4813-8AE6-1A35B5B54971;4A1F8F80-6412-4F9C-8D7C-05D7EF1EBB78;D8DDD577-DAD1-4431-B63A-B98925FADD8E;2E7AFBAA-EF81-436C-A335-5E9A22641506;5A7B28BA-43A4-4C37-AC89-BE698265A1EC;4071554B-A69E-4219-875A-55314269501F;292382E5-B1A4-40AF-855F-2D18104A7316;286A1918-21B6-4D25-99DD-A7C4E9BE6E2A;D0E1A151-7611-4C85-A3D3-7EA9BFF2B3CD;45EAABA6-77C7-4EFF-AE6E-4A8AE1F8EB1F;E38912C0-FBE7-495C-849E-5585D0A1592E;EE691C42-DBB3-4BE5-A341-171EB509812E;


  • dengyejingdengyejing USMember ✭✭

    also has this problem

  • HistoryaHistorya USMember ✭✭✭

    @ruif90 i am getting same message, did you find how to fix it???

  • fdundjerfdundjer RSMember
    edited June 2017

    Same problem here. Has anyone found the fix for this issue?

    ps. This happened after switching user for mac connection.

    • Found the solution, the new user I've created had only standard permissions. After adding admin permissions everything worked fine.
  • npinedanpineda Member ✭✭

    I had the same issue and i resolved it by realizing that my PC with VS was on a different network than my Mac with Xcode. Once i put both machines on the same network the issue went away. Hope it helps.

Sign In or Register to comment.