Errors when adding GooglePlayServices Base.

Luca.9439Luca.9439 USMember ✭✭

Hello,

I am trying to add the GooglePlayServices.Base package to my project but I keep getting errors when doing this. This is my error:

Attempting to gather dependency information for package 'Xamarin.GooglePlayServices.Base.32.961.0' with respect to project 'SNIP', targeting 'MonoAndroid,Version=v6.0'
Attempting to resolve dependencies for package 'Xamarin.GooglePlayServices.Base.32.961.0' with DependencyBehavior 'Lowest'
Unable to find a version of 'Xamarin.Android.Support.v4' that is compatible with 'Xamarin.Android.Support.Animated.Vector.Drawable 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.Design 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.AppCompat 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.MediaRouter 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.v7.RecyclerView 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Android.Support.Vector.Drawable 23.3.0 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.Forms 2.3.3.175 constraint: Xamarin.Android.Support.v4 (= 23.3.0)', 'Xamarin.GooglePlayServices.Basement 32.961.0 constraint: Xamarin.Android.Support.v4 (>= 24.2.1)'.

Anyone knows how to fix this?

Best regards,
Luca Panjer

Answers

  • sylmosssylmoss BRMember ✭✭

    if you are using Xamarin.Forms the only way to use GooglePlayServices.Base is installing the 32.940.0-beta3 version. It is the only one that is compatible with. I use this version in my app, and it works perfectly.

    Xamarin.Forms isn't compatible with Xamarin.Android.Support.v4 >= 24.2.1, that's why it isn't compatible with the version of GooglePlayServices you are trying to install.

    Hope this can help you.

  • This last installation works:
    ?xml version="1.0" encoding="utf-8"?>













  • Momin_AliMomin_Ali Member ✭✭
    edited August 2018















    60.1142.0

    I was integrating push notifications into the project and it had a version conflict with maps.
    this worked for me like a charm !

    hope it helps anyone.

Sign In or Register to comment.