Forum Xamarin.Forms

Xamarin Forms NuGet References Not Downloading (Android)

I have taken the basic MasterDetailPage sample and modified some stuff in the forms project. The Android project is basically exactly as it was when I got it from the Git Repo. It doesn't use project.json It uses packages.config (old school). I'm happy to upgrade to project.json but I can't find any examples of Android projects with project.json.

Anyway, this app was compiling and running fine. Then, I deleted the bin, and obj folders, and I just get compilation errors complaining that the Xamarin Forms library reference is missing. E.g.:
The type or namespace name 'Forms' does not exist in the namespace 'Xamarin' (are you missing an assembly reference?)

I've tried rebuilding, I've tried "Restore NuGet Packages". What can I do to get the references back through NuGet? And why is this still an issue? Why can't the most basic issues be ironed out so we don't end up wasting countless hours just trying to get things to compile?

Best Answer


  • tribaltribal USMember ✭✭✭

    Also check to see if any Import Project elements or its targets in the unloaded csproj are targeting non existent references or paths in the packages folder. These might also be an issue

Sign In or Register to comment.