Xamarin Studio won't start the iOS simulator. No errors, mlaunch in ide.log file, help!

dskidski USMember

As the title says, I can't seem to get Xamarin Studio to start the iOS simulator. I simply click the run button, it builds, I see "Waiting for the debugger to connect to..." for a split second, and then it returns me to the default "Xamarin Studio" status. There are no errors, no messages, nothing.

I think it started happening when I updated to xCode 8.1 and rolled back to 8.0 (Xamarin didn't support 8.1 at the time). I have since updated to xCode 8.1 again. As far as Xamarin Studio goes, I'm on 6.1.2, but this issue has been around for the past few versions too.

Some things to note:

  • This happens even with a simple new iOS solution. The same simple solution on a different Mac with the same versions of everything launches the emulator just fine...so it's definitely something confined to this Mac.
  • I've tried completely uninstalling and reinstalling xCode and Xamarin Studio, no change.
  • I've tried creating a new user account on the computer, no change.
  • If I inspect Xamarin Studio's ide.log file I see the mlaunch command. If I copy that command and paste it into a terminal window, it launches the simulator and app just fine. Progress, but not very helpful as there's no debugger attached. There is also no mention of the mlaunch command in the Mac Console app (there is on the other Mac that launches the simulator successfully).
Sign In or Register to comment.