InspectorPackage not loading properly in VS2015

I have just installed the Xamarin tools for Visual Studio 2015 and started receiving an error when launching an existing project - giving me the cryptic error that Visual Studio could not load the "InspectorPackage" and pointing me to an .xml file. Combing through the file, I came across the following entry:

<entry>
    <record>569</record>
    <time>2016/11/27 23:26:10.554</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>LegacySitePackage failed for package [InspectorPackage]Source: &apos;&apos; Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;   at EnvDTE.Properties.Item(Object index)&#x000D;&#x000A;   at Xamarin.Inspector.VS.VSAgentExecutionTarget..ctor(Project proj)&#x000D;&#x000A;   at Xamarin.Inspector.VS.VSInspectorSession.CreateAgentExecutionTarget()&#x000D;&#x000A;   at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare()&#x000D;&#x000A;   at Xamarin.Inspector.VS.InspectorPackage.RefreshInspectorSession()&#x000D;&#x000A;   at Xamarin.Inspector.VS.InspectorPackage.Initialize()&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description>
    <guid>{0FCBA9C6-0554-418C-8B79-FF2ED7DC658D}</guid>
    <hr>80070057 - E_INVALIDARG</hr>
    <errorinfo></errorinfo>
  </entry>

I checked for updates on the Stable release track, and there are none available, so I'm wondering if I should give the Beta release track a whirl in hopes of correcting this error.

Of course, any other suggestions would be greatly appreciated!

Sign In or Register to comment.