Visual Studio 2015 InspectorPackage package did not load correctly

I have a fresh install of Windows 10, Visual Studio 2015 Update 3, and the latest Xamarin. I get the following error:

The 'InspectorPackage' package did not load correctly.

Here is the info from the activity log:

<entry> <record>673</record> <time>2016/12/27 08:31:15.065</time> <type>Error</type> <source>VisualStudio</source> <description>LegacySitePackage failed for package [InspectorPackage]Source: &apos;&apos; Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A; at EnvDTE.Properties.Item(Object index)&#x000D;&#x000A; at Xamarin.Inspector.VS.VSAgentExecutionTarget..ctor(Project proj)&#x000D;&#x000A; at Xamarin.Inspector.VS.VSInspectorSession.CreateAgentExecutionTarget()&#x000D;&#x000A; at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare()&#x000D;&#x000A; at Xamarin.Inspector.VS.InspectorPackage.RefreshInspectorSession()&#x000D;&#x000A; at Xamarin.Inspector.VS.InspectorPackage.Initialize()&#x000D;&#x000A; at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description> <guid>{0FCBA9C6-0554-418C-8B79-FF2ED7DC658D}</guid> <hr>80070057 - E_INVALIDARG</hr> <errorinfo></errorinfo> </entry>

Any idea how to resolve?

Answers

  • SandyArmstrongSandyArmstrong Sandy Armstrong US Xamurai

    What kind of project is your solution's startup project? It seems this error could happen if the project doesn't have an OutputPath set, but I'm not sure what would lead to that.

  • KeithMcAlpineKeithMcAlpine Keith McAlpine US

    Is this resolved..what is the solution?

  • SandyArmstrongSandyArmstrong Sandy Armstrong US Xamurai

    The fix for this is on the way.

  • OwenGunterOwenGunter Owen Gunter GB

    I get this error grrr!!

      <entry>
        <record>778</record>
        <time>2017/01/31 22:22:08.385</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>LegacySitePackage failed for package [XamarinInspectorPackage]Source: &apos;&apos; Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;   at EnvDTE.Properties.Item(Object index)&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSAgentExecutionTarget..ctor(Project proj) in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSAgentExecutionTarget.cs:line 38&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSInspectorSession.CreateAgentExecutionTarget() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSInspectorSession.cs:line 83&#x000D;&#x000A;   at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\External\inspector-ide-integration\Xamarin.Interactive.IdeSupport\InspectorSession.cs:line 95&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 130&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.Initialize() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 95&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description>
        <guid>{91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}</guid>
        <hr>80070057 - E_INVALIDARG</hr>
        <errorinfo></errorinfo>
      </entry>
    

    Any clues; a fix would be nice. Tried repair, re-install etc and nothing works!

  • OwenGunterOwenGunter Owen Gunter GB
      <entry>
        <record>778</record>
        <time>2017/01/31 22:22:08.385</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>LegacySitePackage failed for package [XamarinInspectorPackage]Source: &apos;&apos; Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;   at EnvDTE.Properties.Item(Object index)&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSAgentExecutionTarget..ctor(Project proj) in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSAgentExecutionTarget.cs:line 38&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSInspectorSession.CreateAgentExecutionTarget() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSInspectorSession.cs:line 83&#x000D;&#x000A;   at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\External\inspector-ide-integration\Xamarin.Interactive.IdeSupport\InspectorSession.cs:line 95&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 130&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.Initialize() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 95&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description>
        <guid>{91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}</guid>
        <hr>80070057 - E_INVALIDARG</hr>
        <errorinfo></errorinfo>
      </entry>
    
  • OwenGunterOwenGunter Owen Gunter GB

    I get this error:

      <entry>
        <record>778</record>
        <time>2017/01/31 22:22:08.385</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>LegacySitePackage failed for package [XamarinInspectorPackage]Source: &apos;&apos; Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))&#x000D;&#x000A;   at EnvDTE.Properties.Item(Object index)&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSAgentExecutionTarget..ctor(Project proj) in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSAgentExecutionTarget.cs:line 38&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.VSInspectorSession.CreateAgentExecutionTarget() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSInspectorSession.cs:line 83&#x000D;&#x000A;   at Xamarin.Interactive.IdeSupport.InspectorSession.Prepare() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\External\inspector-ide-integration\Xamarin.Interactive.IdeSupport\InspectorSession.cs:line 95&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 130&#x000D;&#x000A;   at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.Initialize() in C:\data\lanes\4033\ff5ef6de\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 95&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)</description>
        <guid>{91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}</guid>
        <hr>80070057 - E_INVALIDARG</hr>
        <errorinfo></errorinfo>
      </entry>
    
  • SandyArmstrongSandyArmstrong Sandy Armstrong US Xamurai

    This was fixed several releases ago. Closing.

This discussion has been closed.