Xamarin Mac Agent Broken After Update to Xamarin For Visual Studio v. 4.2.74

After upgrading to the latest version of Xamarin for Visual Studio, I can no longer use the Xamarin Mac Agent - it simply times out without giving an error. I followed Xamarin's Troubleshooting Guide and was able to get through steps 1-12. In other words, SSH is working between both machines.

I also went through the Known Issues and Limitations section but nothing has worked. Again, I am not getting any errors, the Xamarin Mac Agent simply times out while trying to make a connection.

Is there anything else that I can try?


  • NinjaFocksNinjaFocks USMember ✭✭

    We see this intermittently as well - not sure what the problem is. Restarting Visual Studio/the Mac seems to work for us mostly, making sure the Mac is logged in and awake tends to help while we're working and deploying.

  • ruslan.0788ruslan.0788 BYMember

    problem not solved. help, please !

  • Problem is solved on my end. After confirming that release channels on both the PC and the Mac were in sync, I closed all instances of Visual Studio, reopened, and the Mac Agent successfully connected.

Sign In or Register to comment.