Working copy out of date (exception)

Not sure if this is coincident with updating to Xcode 5 and command line tools but I was unable to do a SVN update on my project as I got an error about the working copy being out of date or expiring. I have never seen anything like this and couldn't figure out how to get around it so I had to delete everything on disk and pull a new copy from SVN. Thankfully I didn't have edits locally.

What is the cause and fix for this? I also sure hope XS updates start rolling out. I feel this iOS designer is really holding up the show on XS and getting us fixes and improvements.

Thanks.

Posts

  • I would like an answer to this as well. This happened after I updated to iOS 7, xcode5, etc on my mac. I unfortunately made a lot of changes so I don't want to make a new project and checkout the old project. I'm at the point where I need to do an update to SVN and cannot. The error says it requires SVN 1.7 to post. Searched this issue on the internet and found others with problems when using eclipse and SVN. I'm going to try installing SVN 1.7 using the thermal. found info on this site http://jason.pureconcepts.net/2012/10/updating-svn-mac-os-x/

  • There are some caviots to the info I just posted, i.e. need to update curl command, and problems with doing that. I'd like to know if anyone knows an easy way to fix this problem with Subversion.
    Thanks.

  • OK, I just reinstalled command line tools in XCode 5, restarted my MAC and Subversion is working again.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    Xcode5 uses SVN 1.7. The meta-data strategy changed drastically in 1.7, eliminating the child-level .svn directories among other changes. These need to be upgraded before you can use the working copy with SVN. In previous versions of SVN the upgrade was done automatically on the first svn write operation. In this version, they made it a manual step.

    You can upgrade the working copy via "svn upgrade".

    Don't know if this will solve your issue, but it's worth a try.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @DaveHunt

    Thanks for the info, I'm sure a number of people will find it very helpful!

  • NealCulinerNealCuliner USBeta ✭✭✭

    Do you just run "svn upgrade" from terminal or can someone explain clearly how to do this? Thanks

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    From terminal, cd to the top level of the working copy (the highest level of your project where you have a .svn directory) and run "svn upgrade".

  • NealCulinerNealCuliner USBeta ✭✭✭

    Thanks, will give it a try.

Sign In or Register to comment.