Forum Libraries, Components, and Plugins
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

[HELP] Different in running on Android 4.0 and 5.0

JasonFongJasonFong USMember

Just making an app with CocosSharp particles.
I found it looks different on 2 of my device.

When it run on Android 4.0, it looks alright. But when running on 5.0, it looks like it is not running in rgba8888.

Can anyone help fix this?

on_4.png 1019.9K
on_5.png 707.3K

Best Answer

Answers

  • Ruslan0990Ruslan0990 DEMember ✭✭

    Do you have a changing/ random color in your particle effect? You can set a fixed color on your particle effect if that's what you want.

  • JasonFongJasonFong USMember

    Yes the particle has changing colour effect. But this is not the cause of the problem.
    Even without the particle. It seems like the Colour Depth of the GLSurface running on Android 5.0 or above is not rgb888. The CCGradientLayer background is not smooth at all.
    But everything works ok on Android 4.x.x.

    Does anyone have the same issue?

  • JasonFongJasonFong USMember

    After searching for ways to check the Android Surface. Finally I found the issue is from OpenTK.
    On Android 5.0 or above, it created context with rgb565.
    But on Android 4.4 is can created context with rgb888.

    Could anyone in CocosSharp can help fix this?

    4.png 59.9K
    6.png 76.2K
Sign In or Register to comment.