Why is the Xamarin Profiler not available? (with Enterprise subscription)

DanSiegelDanSiegel USUniversity ✭✭

I'm currently unable to use the Xamarin Profiler. In Visual Studio it's grayed out, and it's just not there in either Xamarin Studio or "Visual Studio for Mac". Is there something special I have to do to activate it? I thought it was just supposed to work if you have an Enterprise license?

I have an active Enterprise license and am running:

  • Visual Studio Enterprise 2015 v14.0.25431.01 Update 3

    • Xamarin 4.2.1.62
    • Xamarin.Android 7.0.2.37
    • Xamarin.iOS 10.2.1.5
  • Xamarin Studio Enterprise

    • 6.1.2 (build 44)
  • Visual Studio for Mac

    • Preview 1 (7.0 build 347)

Best Answer

Answers

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @DanSiegel,

    Did you install the extension? Try starting here and let me know if it's not resolved!

  • DanSiegelDanSiegel USUniversity ✭✭

    @JohnMiller this does fix the issue of it being grayed out in Visual Studio. However it is still not available on the Mac from either Visual Studio for Mac or Xamarin Studio.

    I should clarify it does show up as an install application, however there is no option to launch it from within either IDE.

    As for the Windows install it never seems to actually connect to start profiling.

  • NssNss USMember
    edited March 30

    The same problem with Visual Studio Enterprise 2017 (build 26228.09 and build 26228.10).

    My computer is in active directory. When I run Visual Studio as user the "Analyze -> Xamarin Profiler" menu item is disabled (painted in grey color). But when I run Visual Studio as administrator the "Analyze -> Xamarin Profiler" menu item is available for usage.

    How to fix it?

  • faceoffers28faceoffers28 USUniversity ✭✭✭
    edited June 16

    @JohnMiller This is not working for me either. The option is grayed out under iOS - Properties - Build. The option is also grayed out under Tools - Xamarin Profiler. I am running the Enterprise Version. I am using Visual Studio Premium 2015 Update 5 with ReleaseCycle 9 of the toolset. I downloaded the Xamarin Profiler (1.5) from here. https://www.xamarin.com/profiler

    Any help is much appreciated. Thanks!

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @faceoffers28,

    Make sure the Enable Profiling option is selected for your project.

  • faceoffers28faceoffers28 USUniversity ✭✭✭

    @JohnMiller Please see attached screen shot. The option is there, but it is grayed out.

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @faceoffers28,

    Thanks for confirming! Can you also confirm each of the items listed in the troubleshooting doc for this issue?

Sign In or Register to comment.