[Bug] Another Subversion operation is already in progress

KizmarKizmar USMember
edited September 2013 in Visual Studio

[Working copy is on SVN 1.7]

Keep getting this error every time I try to add a file within Xamarin. It appears to add the file anyway... sometimes, but it doesn't look like it's adding it to SVN.

I should note that at the time of adding files, I'm doing nothing in SVN outside of Xamarin. I do keep a Terminal window open, but have no active activities going on.

I'm also getting "An error has occurred: '<.file path and name.>' is not a working copy" errors when trying to add new files.

I generally use the Terminal client to update and commit, because the Xamarin integration for SVN seems half-baked. The Terminal SVN client has no issues updating or committing during all this (my working copy should be fine).

Posts

  • KizmarKizmar USMember

    OK, so I tried to update the solution IN Xamarin and I'm getting this: "Version control operation failed: . The path ' ... ' appears to be part of a Subversion 1.7 or greater working copy. Please upgrade your Subversion client to use this working copy."

    I've already updated the command line tools in Xcode after updating for iOS 7. I also installed the SVN 1.7 client and added "export PATH=/opt/subversion/bin:$PATH" to my .bashrc file to use in Terminal.

    I'm somewhat new to Mac's, and I'm not sure what I need to do here so Xamarin uses SVN 1.7.

  • KizmarKizmar USMember

    After installing the new command line tools, a reboot allowed me to run the SVN update command within Xamarin.

    I'm still getting the "Another Subversion operation is already in progress" error when trying to add new files or folders though.

  • We are getting this error too all the time, but only when you commit from the "Review solution changes" window. It seems the this window wants to update itself while the changes are still being committed. You won't get the error if you close that window after starting the commit, but before the process has completed.

  • KizmarKizmar USMember

    I've disabled the SVN add-in in Xamarin and am using Terminal to do all of my SVN commands now.

  • NealCulinerNealCuliner USBeta ✭✭✭

    Joy - I get this too! I don't think anyone at Xamarin uses SVN :)

  • KizmarKizmar USMember

    Yeah, given the choice I wouldn't either; I'd be using Git... but I don't have a choice in this case. ;)

    I've gotten used to using SVN in Terminal and turning it completely off in Xamarin. It does the trick.

  • NealCulinerNealCuliner USBeta ✭✭✭

    I may have to rely on my Cornerstone Mac App for SVN in the interim. Nice app, just another added layer though.

  • KizmarKizmar USMember

    I used Cornerstone during it's trial period, it is a nice app. I didn't want to fork up the money for it, so I forced myself to use the SVN command line tools. ;)

  • NealCulinerNealCuliner USBeta ✭✭✭

    Has anyone reported this to Xamarin via bugzilla?

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    Except that the bug report shows it was fixed in July. So, either this is a new error or a subsequent release undid the fix or the original fix wasn't a complete fix.

    I would suggest that someone experiencing this problem open a new bug report.

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    More fixes have been issued to this. They are currently in the alpha channel. If this is indeed a regression and happens in alpha, I will wait for a follow-up.

  • AlanTonissonAlanTonisson AUMember ✭✭

    I'm getting this error now.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @AlanTonisson with what version? What OS?

  • AlanTonissonAlanTonisson AUMember ✭✭

    I'm using the latest stable version of Xamarin (7.2?) on OS X. My OS X is also up to date. Don't have access to it right now, so I can't check the version.
    Checkin seems to work - the only problem seems to be the error message.

  • AlanTonissonAlanTonisson AUMember ✭✭

    Sorry 7.2 is the Xamarin.iOS version.
    I'm using Xamarin.Android right now, so that would make the version Xamarin.Android version 4.12.1, with version 4.2.3 of Xamarin Studio.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @MariusUngureanu is there any information that would help tracking this down?

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    Yeah. I have tracked down the cause and I'm looking into fixing it.

  • This doesn't seem to be fixed. I've experienced the same issue when adding new files or new folders.

Sign In or Register to comment.