Forum General

Stable Channel: Cycle 8 – Service Release 1

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
edited November 2016 in General

Please see for the details about this release, including the steps to update or downgrade as needed.

Bug reports wanted!

  • Please file a quick bug report using the "Cycle 8" new bug form if you see any behavior that looks suspicious in these versions (and if it isn't clear whether one of the known issues in the release notes matches the problem).

    • If you get any errors when using the form to submit, please select the All Products option and choose the desired product.
  • Comment in this forum thread if your question is not related to a suspicious behavior after installation, but instead one of the following:

    • You notice an error in the Release Blog post.
    • You have trouble downloading one of the installer packages.

Remaining higher-visibility known issues from the list for the previous release

None. This release includes candidate fixes or improvements for each of the higher-visibility known issues that were listed in the forum announcement for the previous release.

Fixed bugs

You can view the list of bugs addressed by this version using the following Bugzilla query:

Open bugs list

You can view all of the remaining bugs that have been reported against the Cycle 8 version that are not yet fixed in "Cycle 8 – Service Release 1" using the following Bugzilla query:

Some higher-visibility known issues from the open bug list

  • [Xamarin for Visual Studio], [Xamarin Studio] - Upcoming compatibility feature, tracked in 44330 - "This version does not have support for files saved in Xcode 8 format" appears when attempting to edit a file with the Xamarin iOS designer after having edited the file with Xcode 8. Xcode 8 introduced a new, non-backwards-compatible XML format for Interface Builder documents that is not yet supported in Xamarin's iOS designer. As it turns out, Xcode 8.1 from Apple has in fact backed out of several of those format changes. Candidate fixes are now under test for Xamarin's iOS designer to cover the remaining format changes as present in Xcode 8.1.

  • [Xamarin Studio] - 43188 - Sporadic "Out of memory" error during build leaves solution in an unbuildable state until the project is reloaded.

    • Improved in this release: Cycle 8 Service Release 1 includes some fixes that should hopefully eliminate the need to reload the project in this scenario. Additional fixes for the "Out of memory" error itself are also planned.

EDIT Nov 14: Correct a typo in the fixed bugs query.


  • hemanthemant USMember ✭✭

    The release notes link for Xamarin Studio 6.1.2 in the Update dialog points to a wrong URL:

    It should be

  • LjusnanLjusnan DEMember ✭✭✭

    The link to the fixed bugs is not working. I get a "Software Error".

  • jzeferinojzeferino USUniversity ✭✭
    edited November 2016

    Can't deploy to Genymotion with this new Xamarin release the output error is:

    Deployment failed because of an internal error: Unexpected install output:  pkg: /data/local/tmp/Mono.Android.DebugRuntime-x86.apk
    Deployment failed. Internal error.

    And somethimes I get:

    Deploying package to ''
    Detecting installed packages
    Installing platform framework
    The device was disconnected. Please reconnect it and try again.

    Deployment failed. Device disconnected.
    Should I open a bugzilla issue for that @BrendanZagaeski ?
    Note: it work on device and google emulator.

    ------------------------------- UPDATE -----------------------------

    Ended up running the Xamarin installer again and it fixed it.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    The link to the fixed bugs is not working. I get a "Software Error".

    Thanks for the heads-up! The typo in the link that was causing that should be fixed now.

    The release notes link for Xamarin Studio 6.1.2 in the Update dialog points to a wrong URL:

    Thanks for the heads-up! I have requested a typo correction for that URL now too.

  • TonyMcCarthyTonyMcCarthy GBUniversity ✭✭

    The IOS Windows simulator no longer works. I keep on getting this error:-

    Xamarin Simulator

    Failed to install //Users/Username/Library/Caches/Xamarin/mtbs/builds/MyApp_IOS/c376935bf9404592497ac41462cd1465/bin/iPhoneSimulator/Debug/ to 4D9D13A9-437F-4356-B21C-C0FA8D65B78C

    It used to work fine, but stopped working in the previous stable release.

    I have tried all of the suggested worarounds to no avail.

    Any ideas ?

  • TonyMcCarthyTonyMcCarthy GBUniversity ✭✭

    The release notes seem to suggest that the issue "Android Designer shows progress indicator indefinitely" has been addressed (items 44997 and 43948).

    I am still getting the same issue in the latest stable release (.58).

    Are there still known issues with this ?

  • dg78dg78 FRMember

    I have a very big problem, I can not install this version and now I can not use Xamarin.

    see the attach file

    It is the same if I try to repair or uninstall Xamarin.

    What can I do to solve that ?

    I am now completely blocked and I can no longer use Xamarin.


  • I have a problema when I try to install the last update stable.


  • Surprise, Surprise....... I t looks like to use the iOS Simulator in Windows you now must have Visual Studio Enterprise. I hope I am wrong but I noticed that when I did the latest upgrade to stable the check box to enable the iOS Simulator in Windows was no longer available. I then looked at the docs for the iOS Simulator for windows it now says Visual Studio Enterprise.
    If this is true then this would be a terrible move on Xamarin's part. It could be the first step in clawing back free features to paid subscriptions.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited November 2016

    Android Designer shows progress indicator indefinitely
    Are there still known issues with this ?

    The closest remaining open bug report is perhaps:

    Bug 45278 - VS2015: Any time the designer has been opened the next build hangs VS until I kill java.exe

    The other note that might be relevant is to double-check that 64-bit Java JDK 8 (1.8) is installed and set as the active version under Tools > Options > Xamarin > Android Settings > Java Development Kit Location. There were some fixes around missing error messages for that scenario, but it's possible there might be some remaining edge cases that still show a loading indicator indefinitely rather than properly surfacing the error message.

  • NMackayNMackay GBInsider, University admin
    edited November 2016

    This version sneaked out yesterday (I think there were two releases in the "stable" channel) breaks compiling against Forms 2.3.2 stable. Updating to 2.3.3. pre-4 fixes this. Version for Visual Studio 2015.

    Severity    Code    Description Project File    Line    Suppression State
    Error       Position 77:12. No property, bindable property, or event found for 'Height' AppName 
    Error       Position 901:30. No property, bindable property, or event found for 'Width' AppName

    Same old story with stable releases of late.

  • TonyMcCarthyTonyMcCarthy GBUniversity ✭✭

    Visual Studio 2015 - Xamarin


    I found a way to make the Android XAML designer work. Originally I could not open any XAML files. Then in solution explorer, I right clicked an Android layout xaml file and selected "Open with". This brought up a list of choices and I selected the default entry "Android Layout File" and then clicked the "Set as Default" button (despite the fact that it was already the default). I then exited Visual Studio and it started to work as it should do.

    It is still a bit hit and miss, but when it fails now I usually restart visual studio and it fixes it.

    Also, I have an Enterprise license but still have issues with the IOS Simulator for Wndows as pointed out in the earlier post (keep getting error Failed to install //Users/Username/Library/Caches/Xamarin/mtbs/builds/MyApp_IOS/c376935bf9404592497ac41462cd1465/bin/iPhoneSimulator/Debug/ to 4D9D13A9-437F-4356-B21C-C0FA8D65B78C).

  • Michael_ShapiroMichael_Shapiro USMember ✭✭✭

    Does anyone know the reason why duplicate widgets appear in the Toolbar?
    Possibly related question - when opening a layout in the designer I (sometimes) see a "Loading Layout" green progress bar and the layout never loads. I have to restart the VS to fix this. It all started right after I updated to the latest Xamarin (

    Here is my system:

    Microsoft Visual Studio Professional 2015
    Version 14.0.25431.01 Update 3
    Microsoft .NET Framework
    Version 4.6.01586

    Xamarin (47830f6)
    Xamarin.Android (ce955cc)
    Xamarin.iOS (44931ae)

  • dpedrinhadpedrinha DEMember ✭✭✭

    And so the red underlined InitializeComponent() bug is back. UNBELIEVABLE!

  • GaborFurediGaborFuredi HUMember ✭✭
    edited November 2016

    I can't deploy Android projects anymore with this latest release. Neither to devices nor to emulators.

    Error message:

    "Detecting installed packages

    Installing shared runtime

    The device was disconnected. Please reconnect it and try again.

    Deployment failed. Device disconnected."

    Never had issues like this before. Opened a ticket for it. Seems to be similar to what @jzeferino mentioned.

This discussion has been closed.