Forum Xamarin.Android

Problems installing on windows

LesFergLesFerg NZMember ✭✭
edited September 2013 in Xamarin.Android

I tried to install on windows 7 64bit, and the installer stopped with errors, such as

[Info] DEBUG: Error 2711:  The specified Feature name ('MonoDroidSDK') not found in Feature Table.
[Info] MSI (s) (8C:F8) [13:13:32:447]: Product: Xamarin.Android -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: MonoDroidSDK, ,
[Info] The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2711. The arguments are: MonoDroidSDK, ,

and...

[Info] MSI (s) (8C:F8) [13:13:32:457]: Windows Installer installed the product. Product Name: Xamarin.Android. Product Version: 4.8.01013. Product Language: 1033. Manufacturer: Xamarin. Installation success or error status: 1603.

I manually installed mono-android-4.8.01013.msi from the temp folder, and that completed ok. The installer now runs thru completely but there have been no links added to the windows menu under the Xamarin folder for Xamarin studio or anything else other than the android SDK link. Is there a repair tool to make sure I now have everything installed correctly?

Also, I could not find any option to change the installation drive, and I really did not want to install all of this on my SSD drive, how do I change the installation to use a different drive?

Posts

  • StevenTheEvenStevenTheEven SEMember ✭✭✭

    I suggest you remove EVERYTHING and try to install from beginning again. Do and uninstall from Programs and Features and also remove the dirs where it gets installed.

Sign In or Register to comment.