When I am trying to add the Sqlite-net-pcl for android platform I am getting the below error

Install-Package : Unable to resolve dependencies. 'Xamarin.Android.Support.v4 23.0.1.3' is not compatible with 'Xamarin.Android.Support.Design 23.0.1.3 constraint: Xamarin.Android.Support.v4 (>=
23.0.1.3)', 'Xamarin.Forms 2.2.0.45 constraint: Xamarin.Android.Support.v4 (= 23.3.0)'.
At line:1 char:1

  • Install-Package sqlite-net-pcl
  • ~~~~~~
    • CategoryInfo : NotSpecified: (:) [Install-Package], Exception
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

how to rectify this.

Tagged:

Answers

  • mattwardmattward GBMember Xamurai

    Uninstall all the Xamarin.Android NuGet packages and then just install the Xamarin.Forms NuGet package. The required Xamarin.Android NuGet packages will be installed when you install the Xamarin.Forms NuGet package.

  • navinkumarDnavinkumarD USMember ✭✭

    @mattward Ok Will Try that. thank you

  • that did't work for me! anyone?

Sign In or Register to comment.