Not built in active configuration

wallymwallym USInsider, Beta ✭✭✭

in XS, what does "not built in active configuration" mean? It just started being displayed this afternoon. Is there some way to work around this? Seems strange.


  • JonasRembrattJonasRembratt SEUniversity ✭✭✭

    How old is this thread? I have the same problem and I also experience issues with how XS resolves breakpoints that indicate some projects are not being built correctly. I have tried cleaning and rebuilding individual projects but I still see the "(not build in active configuration)" message next to all projects except the active one.

    Also, there is no option called "Configurations" under the "Build" menu.

    Is this thread very old and, if so, how to fix this in XS 4.2.2?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    The Configurations options aren't in the Build menu, they are in the Build section of the Solution Options.

    Double-click on your solution and navigate to the Build section, under that will be "Configurations".

    Hope that helps clarify.

  • carleslscarlesls ESMember

    The Configurations options aren't in the Build menu, they are in the Build section of the Solution Options.

    Double-click on your solution and navigate to the Build section, under that will be "Configurations".

    Hope that helps clarify.

    What's a platform?
    How can I define a platform in the Configurations options... should I just write down Android or Android Simulation where it says Any CPU?

  • Thank you Marius! I spent last hour trying to figure that out :)

  • Thomas.8953Thomas.8953 USMember

    I'm on Xamarin Studio 5.9.1 on a Mac and there is no Configuration Mapping Tab there.

  • akashvermaakashverma USMember ✭✭

    Do not right click on iOS project, if you right click on solution-> Options->Build->Configuration, there you can find Configuration mapping tab.

  • AlexPobudaAlexPobuda USMember

    I just want to say thank you for this post. My team has been fighting not being able to PCL debug forever now in Xamarin Studio. This was the solution.

  • ChrisColeTechChrisColeTech USMember ✭✭✭

    I also had this issue. This was my solution also.

    Perhaps the tool tip can be a bit more descriptive, and actually offer steps to correct the problem so that we do not have to search the web for answers?

  • ElenaBolpachovaElenaBolpachova USMember ✭✭

    Hi, I have the same issue, and have done what you guys suggested - I created a configuration that includes the projects in question, however even after it said it saved the solution, I still have the same problem... Even more frustrating, because the projects cannot be built in active configuration, the other projects in the solution which reference them have errors, because they are using classes and functions from these projects. It's like the projects aren't even there... Please help!

  • ElenaBolpachovaElenaBolpachova USMember ✭✭

    Hi @JGoldberger and thanks for replying so quickly! :)

    Unfortunately, I cannot yet post links, as I haven't used the forum before :(

    I did come across your blog post for configurations, and it helped me find the menu and understand what I need to look for. When I first loaded the solution, the column Build was unticked for the projects in question, so I ticked them in both the Debug and Release configuration (I am doing a bit of refactoring on an existing customer app).

    Perhaps there's some preferences/config or assembly file that I'm missing or need to change?

    I only get this error when trying to build the solution on the Mac, my Windows machine builds it ok, but I need the Mac to build it too, because I need to test it on an iPad and from the Mac it's easier.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai


    You did not mention whether you checked those projects for build for the correct Platform. If you are deploying to a physical iPad, make sure the Platform is iPhone which is the platform for any iOS physical device whether iPhone, iPad or iPod Touch. Platform iPhoneSimulator is for when you are deploying to a simulator.

    You should be able to add a screenshot without providing a link. If you click the little image icon in the toolbar above your text entry field for your post there should be a button to "Choose files" which should let you select an image from your computer to upload and display in your post.

  • ElenaBolpachovaElenaBolpachova USMember ✭✭

    Hi again, @JGoldberger and thanks for the clarification!

    Under IPhoneSimulator it just doesn't seem to remember my choice, but when I plugged in the iPad, all of the projects now build in active configuration. I even tried creating a copy of the simulator configuration for the simulator platform, and again nothing...

    It's interesting that when I create a new solution and play around with configurations, I don't have this problem. Must be something in this solution's preferences that I haven't yet figured out...

    I tried uploading a screenshot via the Choose files option, and it still treats it as a link and tells me I cannot upload it.

    It looks something like this when I try to upload : ""

    I guess I'll just use the iPad for now. Thanks for your help! :)

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Can you select iPhoneSimulator in the platform drop down at the top? E.g.:

  • Hayden_HancockHayden_Hancock USMember ✭✭
    edited March 2018

    @JGoldberger Changing the build configuration resolved this for me. I experienced this when working between a macOS and Windows environment. I guess I will have to come up with a commit strategy (possibly just creating a separate solution file for each environment?) for a team that has a mix of Windows and macOS developers that use the same GitHub repository.

  • dinobdinob USUniversity ✭✭✭

    having same issue and as Jgoldberger suggested, in Mac, r-c on solution > Options > Build > Configurations > Configurations Mappings and make sure you check the checkbox for build configuration for your IOS project as JGoldberger suggested above.
    After this, the blue icon with "i" in it beside your IOS head project will still be present.
    Unload project, then reload it again (r-c on iOS proj > unload, then r-c on it again > relaod)
    Now the blue icons should be gone.

    If it is still present, make sure to update references / packages if needed. Expand these and check that none of them have some warning sign or error sing beside them and are not grayed out. If grayed out, re-add them

  • seomelon02seomelon02 Member

    Thanks for the good ideas to bring it. I know a lot more. :) :J

  • rahtriparahtripa USMember ✭✭

    Please select Main project ( Solution ). Options > Build > Configurations > Configurations Mappings

  • SuchithSuchith INMember ✭✭

    @JGoldberger @rahtripa Thanks for the guideline, that helped. :smile:

Sign In or Register to comment.