Forum Libraries, Components, and Plugins

SignaturePad works on iOS simulator, not on iOS physical device

I am using SignaturePad in a PCL project. Pad works great on Android, no issues. I can use the Pad on iOS simulator - 6s 9.3. I can't verify image capture as I have GPS location requirements coded in app which is not supported in simulator - at least MacInClouds. When I deploy it to App store/test flight and run on my personal phone the signature pad displays. The signature "X", line and clear don't show up. The pad doesn't even respond to my signing with my finger. Is there a "touch/gesture" permission that is required?
Thanks, Glen


  • RussellCollinghamRussellCollingham GBUniversity ✭✭

    Glen it's being removed by the linker. Add this line in the AppDelegate.cs file

        public partial class AppDelegate : global::Xamarin.Forms.Platform.iOS.FormsApplicationDelegate
            public static Type dummyt = typeof(SignaturePad.Forms.iOS.SignaturePadRenderer); //<<<--------
  • GlenMeredithGlenMeredith USMember ✭✭

    Thanks for replying. I thought I had closed this one as someone replied with a fix. I did originally have your line of code. However, it didn't work on the physically device. I ended up doing this and everything works.

            SignaturePad.Forms.iOS.SignaturePadRenderer renderer = new SignaturePad.Forms.iOS.SignaturePadRenderer();
            SignaturePad.Forms.SignaturePadView signature = new SignaturePad.Forms.SignaturePadView();

    I never tried it with just the View. The above worked so my 1st app is back on track.
    Thanks again for responding.

Sign In or Register to comment.