Xamarin Profiler in VS shows the message "Sorry, something went wrong trying to run .app".

WVercWVerc NLMember ✭✭

When starting the Xamarin Profiler (version 0.34.1.0) in VS it shows the message "Sorry, something went wrong trying to run .app". The log file shows the following entries:

INFO[2016-09-16 22:01:52Z]: initializing android platform
INFO[2016-09-16 22:01:52Z]: initializing ios platform
INFO[2016-09-16 22:01:52Z]: initializing mlpd platform
INFO[2016-09-16 22:01:52Z]: ##########################################
INFO[2016-09-16 22:01:52Z]: # Xamarin Profiler version - 0.34.1.0
INFO[2016-09-16 22:01:52Z]: # * Arch x86_64
INFO[2016-09-16 22:01:52Z]: ##########################################
DEBUG[2016-09-16 22:01:52Z]: processing command line = C:\Program Files (x86)\Xamarin\Profiler\XamarinProfiler.exe --type=ios --target=/Users/test1/Library/Caches/Xamarin/mtbs/builds/test.iOS/4cb23c5f2c91fdeedc0abaeea2de2d9c/bin/iPhoneSimulator/Debug/testiOS.app --device=:v2:udid=0E2261C0-AC29-4066-84DF-5980D084A710|9.3 --options=host:10.211.55.2,port:54345,user:test1,family:ios,name:iPad 2 iOS 9.3
DEBUG[2016-09-16 22:01:57Z]: instrument added
DEBUG[2016-09-16 22:01:57Z]: Progress report initialized successfully
DEBUG[2016-09-16 22:01:57Z]: Connecting to 10.211.55.2 as test1
DEBUG[2016-09-16 22:01:57Z]: Connecting to Xamarin Mac agent at 10.211.55.2
INFO[2016-09-16 22:01:58Z]: StartRecording for testiOS.app
DEBUG[2016-09-16 22:01:59Z]: Deploying profiler agent to 10.211.55.2
ERROR[2016-09-16 22:02:20Z]: error occured on run testiOS.app connection couldn't be established: The operation has timed out.
ERROR[2016-09-16 22:02:21Z]: Error occured on run testiOS.app: connection couldn't be established: The operation has timed out.
ERROR[2016-09-16 22:02:21Z]: error occured on run testiOS.app An error occured on client profiler948WielV while executing a post for topic xp/0.34.1.0/stop-profiling
DEBUG[2016-09-16 22:02:21Z]: Stopping profiler log reader

Any idea how we can fix the error?

Thanks.

Posts

  • Same problem here on multiple machines. I'm using Mac OS 10.11.1, XS Beta 6.1 (build 5441) and X Profiler 0.34.2-6

    "An error has occurred
    Could not open /var/folders/wz/....../kop3kcbu.mlpd"

    Is there any solution to this problem?

  • Changed output location to /Users//Documents/tmp and can see MLPD file being created. However, Profiler keeps failing with 'Could not open ...mlpd' file message. I read in other tickets that the MLPD file format has changed. Even double clicking on file fails with same error.

    It seems that Xamarin Profiler can't read the new MLPD file.

    Xamarin, any comments please.. Thanks

  • RodrigoMoyaRodrigoMoya ESXamarin Team Xamurai

    This seems to be the same cause that was making the 0.34.1 Mac UI crash , so please, can you test with 0.34.2? And, if it fails, please also attach the Mac-side logs (in ~/Library/Logs/Xamarin-99.0)

  • mveroukismveroukis CAMember ✭✭✭
    edited February 7

    Any news on this? I have no way to profile my iOS app right now.

    I'm getting the same error from VS2015 Enterprise. For some reason, Xamarin Studio on the Mac has problems building my solution as it errors out on my NuGet packages - it seems the way VS2015 adds them to the project is not compatible with how XS expects it. And the Instruments tool is useless to me as the app launches but freezes on the launch screen, never getting past it.

    And yes I checked for updates, both my PC and Mac are all update date.

  • BrentHamstreet.7868BrentHamstreet.7868 USUniversity

    Make sure the Xamarin Profiler works on the Mac by running it directly, outside the context of Xamarin Studio. In my case the profiler was crashing because I didn't have the Android SDK installed (that's another issue for Xamarin to fix). After installing the Android SDK, profiling worked fine in both Xamarin Studio and, on the PC side, Visual Studio 2017.

Sign In or Register to comment.