Build error on iPad

LGMaestrelliLGMaestrelli BRMember ✭✭✭

We are facing a problem when build and deploy to a iPad device.

Failed to resolve "System.Void ObjCRuntime.UserDelegateTypeAttribute::.ctor(System.Type)" reference from "Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065"

The build and deploy on the simulator works fine.

We are using Xamarin Forms 2.3.1.114,
Xcode 7.3.1
Ipad Air running 9.2.1

Any ideas about it?

Tagged:

Posts

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    Up

  • 1+
    Same problem here. Exactly.
    Can deploy to any simulator, but not to any iPad or iPhone device. Tried fooling with the linker settings. Also deleted obj/bin, etc. No Luck.
    Provisioning profiles all set up and have working for a long time. No problem there.

  • If I set the Linker Behavior to 'Don't link', I get a different error:

    Could not AOT the assembly '.../obj/iPhone/Debug/mtouch-cache/64/Build/HockeySDK.iOSBindings.dll'

    I am pretty sure this means that the dll is too large for iOS, but again, when the linker is set to "Link SDK Assemblies" or "Link All Assemblies", I get the following error:

    Failed to resolve "System.Void ObjCRuntime.UserDelegateTypeAttribute::.ctor(System.Type)" reference from "Xamarin.iOS, Version=0.0.0.0, Culture=neutral ...

    Any suggestions anyone has would be super-duper awesome.
    Thanks in Advance

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @RobinSchroeder.8683

    I found out that this is an error on the HockeyApp...

    https://support.hockeyapp.net/discussions/problems/62772-ios-build-error-on-xamarinforms

    They told me to clean the cache (Sounds like a web application excuse), but didn't work.

    I'm waiting for them to responde.

  • @LGMaestrelli
    Thank you for the response!
    I JUST upgraded from HockeyApp 4.1.0.2 to 4.1.0.3 this morning. So that makes sense.
    Please let me know if they get back to you. If I have time this morning, I will try to roll back and see if the problem persists.

    THANK YOU!

  • softlionsoftlion FRBeta ✭✭✭
    edited September 2016

    +1 !
    Just upgraded from HockeyAppSDK beta to final version this morning, and i'm getting this error.

  • softlionsoftlion FRBeta ✭✭✭

    +1 !
    Just upgraded from HockeyAppSDK beta3 to stable version this morning, and i'm getting this new error.

    I've not updated to Xamarin C8 yet because of the android vs bug. Maybe you need C8 (ie current Xamarin Stable release) to make it compile fine.

    I've downgraded to beta3 and it compiles fine again.

  • @softlion @LGMaestrelli
    Looks like there is a problem in that latest release of Hockey App 4.1.0.3. There is a place somewhere in their code where they need to add that preserve attribute to make the linker not loose the link.
    The problem is really only a brick-wall blocker when your app is too large to be dev deployed to a device without the linker. Otherwise, you can turn the linker off an go about your merry development way...until you decide to actually deploy...

    So, this should probably be a formal bug for the iOS Hockey App 4.1.0.3 distribution. Any thoughts?

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @RobinSchroeder.8683

    Can you post this on HockeApp forum?

    https://support.hockeyapp.net/discussions/problems/62772-ios-build-error-on-xamarinforms

    So we can make the post more active and hope that they will pay more attention.

    Thanks

  • Thank you, I just posted. I was only able to make it work by uninstalling hockey app all together in my app. I don't have a bunch of time right now, but I will revisit to see if I can just reinstall the older version and make it work.

  • DarioOrgazDarioOrgaz USMember ✭✭
    edited October 2016

    I had the same problem and I fixed it updating Xamarin Studio to lastest version.

  • Hello everyone,
    please have a look at my comment in the issue in github and apologies from our side on the long wait time.

Sign In or Register to comment.