Help with new deployment issue for my Forms app - INSTALL_FAILED_DEXOPT - from xamarin studio

2»

Posts

  • Shane000Shane000 USMember ✭✭✭

    I gave up on simulator for now and I'm using a 6p running 7.0 and I'm getting this now:

    Deployment failed because of an internal error: Failure [INSTALL_FAILED_INVALID_APK: Package couldn't be installed in /data/app/XXXXX.YYYYY.ZZZZZ.android-1: Package /data/app/XXXXX.YYYYY.ZZZZZ.android-1/base.apk code is missing]
    Deployment failed. Internal error.

    It sounds like this is related to the final post of yours @JonDouglas

    If a workaround is found could someone post it here or bugzilla? Thanks.

  • 15mgm1515mgm15 USMember ✭✭✭

    Using the last updates I am still having the same issue.

  • GizmoGizmo CLMember ✭✭

    @15mgm15 said:
    Using the last updates I am still having the same issue.

    Yeah, i don't think this update fixes our problem. I was looking at the log and this is not mentioned.

  • GizmoGizmo CLMember ✭✭

    Has anyone tried a clean install of Xamarin and see if this fixes the problem?

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    This issue is not resolved yet. Please refer to bugzilla on a current status:

    https://bugzilla.xamarin.com/show_bug.cgi?id=44633

    You can see the current fix via a pull request here:

    https://github.com/xamarin/xamarin-android/pull/236

  • WilliamSRodzWilliamSRodz BRInsider, University, Developer Group Leader ✭✭

    @JonDouglas when this will be included in a service release?

  • Shane000Shane000 USMember ✭✭✭

    Is anyone hitting this on Xamarin Studio windows? I'm going to setup xamarin studio and everything on a windows box so I can get passed this for the week. I assumed this was only happening on Mac but maybe it's happening on Windows too and that'd be a waste of my time.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @WilliamSRodz

    Once a fix is completely done, there will most likely be a hotfix as our Service Release 0 was released last Friday.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @ShanePope

    I would recommend not installing Xamarin Studio on Windows as we no longer offer it in our installer:

    https://www.xamarin.com/faq#xpq6

    This bug is not present inside Visual Studio, it's only on Xamarin Studio Mac.

  • AdrianKnightAdrianKnight USMember ✭✭✭✭

    I've never seen DEXOPT error, but when I come across an installed failed issue, I uninstall the app from the Android application manager and deploy it again. Not sure if this would resolve your issue since it seems to be related to something else.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @AdrianKnight

    The DEXOPT error only occurs with devices where multidex isn't enabled by default (i.e. < API 19). The main issue is that Xamarin Studio has a build task that is not firing off which causes the main classes.dex list to not deploy to the device.

  • Shane000Shane000 USMember ✭✭✭
    edited September 2016

    http://motzcod.es/post/150380059392/preparing-machines-for-xamarin-cycle follow this guide for making sure your build is setup correctly everyone in this thread.

    Edit: This doesn't fix the issue, but it's good to make sure you have no other issues blocking you.

  • AlejandroRuizAlejandroRuiz MXInsider ✭✭

    I dont know if this is your case but I was able to fix this by removing this 3 nuget packages from my project

    Microsoft.Net.Http
    Microsoft.Bcl
    Microsoft.Bcl.Build

    and reference Net.Http lib via References/All/System.Net.Http

  • 15mgm1515mgm15 USMember ✭✭✭

    @AlejandroRuiz Solution did work for me, I was able to compile w/o issues.

  • WilliamSRodzWilliamSRodz BRInsider, University, Developer Group Leader ✭✭
    edited October 2016

    This is a weak workaround, there is some many nuget packages that depends on this three references (example https://www.nuget.org/packages/Microsoft.Azure.Mobile.Client/), you will get another headache by remove them.

    I'm wondering why took som many time to release this, as we know that the PR with the fix was added weeks ago.

  • AlejandroRuizAlejandroRuiz MXInsider ✭✭

    @WilliamSRodz did you tried using Microsoft.Azure.Mobile.Client only in your PCL and removing it from your Android project?

  • WilliamSRodzWilliamSRodz BRInsider, University, Developer Group Leader ✭✭

    @AlejandroRuiz I used the Microsoft.Azure.Mobile.Client as example ;)

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    @JonDouglas sorry, but I have not understand how to resolve this problem...

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai
  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    Xamarin Studio Indie
    Version 6.1.1 (build 17)
    Installation UUID: 3f1ef7a2-17e7-4995-9b35-52dda7b17de7
    Runtime:
    Mono 4.6.1 (mono-4.6.0-branch-c8sr0/ef43c15) (64-bit)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 406010005
    

    NuGet
    Versione: 3.4.3.0

    Xamarin.Profiler
    Non installato

    Apple Developer Tools
    Xcode 8.1 (11544)
    Build 8B62

    Xamarin.iOS
    Version: 10.2.0.4 (Xamarin Indie)
    Hash: b638977
    Branch: xcode8.1
    Build date: 2016-10-25 14:38:48-0400

    Xamarin.Android
    Versione: 7.0.1.3 (Xamarin Indie)
    Android SDK: /Users/alessandrocaliaro/Library/Developer/Xamarin/android-sdk-macosx
    Versione di Android supportate:
    4.4 (livello API 19)
    4.4.87 (livello API 20)
    5.0 (livello API 21)
    5.1 (livello API 22)
    6.0 (livello API 23)
    7.0 (livello API 24)

    Versione degli strumenti SDK: 25.2.2
    Versione degli strumenti della piattaforma SDK: 25
    Versione degli strumenti di compilazione SDK: 24

    Java SDK: /usr
    java version "1.8.0_45"
    Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

    Il codice EPL di Android Designer è disponibile qui:
    https://github.com/xamarin/AndroidDesigner.EPL

    Xamarin Android Player
    Non installato

    Xamarin.Mac
    Version: 2.10.0.105 (Xamarin Indie)

    Build Information
    Release ID: 601010017
    Git revision: 44d481a9be9cf2bf7c01bfb99c59b77dfa08e712
    Build date: 2016-10-25 14:27:24-04
    Xamarin addins: 19cdb28081bf28d9688698030abb96e04e391f69
    Build lane: monodevelop-lion-cycle8-sr0

    Operating System
    Mac OS X 10.11.6
    Darwin MacBook-Pro-di-Alessandro.local 15.6.0 Darwin Kernel Version 15.6.0
    Thu Sep 1 15:01:16 PDT 2016
    root:xnu-3248.60.11~2/RELEASE_X86_64 x86_64

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    I have deleted all Bin and Obj directories. Now I have INSTALL_FAILED_UID_CHANGED. Trying to change package name, but nothing...

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @AlessandroCaliaro You are still on Xamarin.Android Versione: 7.0.1.3 (Xamarin Indie). As mentioned earlier you need to be on 7.0.2.

    INSTALL_FAILED_UID_CHANGED is a completely different error. You should open up a new forum post for this.

    For that error, you should use adb uninstall <package name> which should also clear /data/data folders. If not, then use Android Device Monitor and find the culprit folder.

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    So do I have to install all things in "beta"?
    Mono framework 4.6.2.6
    XS 6.1.2
    Xamarin Android 7.0.2.38
    etc
    etc

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai

    @AlessandroCaliaro That is correct! You mainly just need Xamarin.Android 7.0.2+ here, but please install everything you are prompted with.

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    I am downloading... slowly...

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    @JonDouglas excellent. Solved

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    @JonDouglas the DEXOPT problem is solved but BETA give me a lot of other problems and crashes... I have chat with

    with @JohnMiller . He know problems... So I am from the start, returned to STABLE with DEXOPT problem

2»
Sign In or Register to comment.