Forum Xamarin.iOS

Can't deploy iOS app in release mode

MattJackMattJack FRMember ✭✭

With latest stable ( I want to deploy my app in Release mode on device, from visual studio 2015 (update 1)
But the app is not deployed (not appearing on ipad desktop)

Repro :
In VS I select release configuration.
I hit CTRL+F5; Compilation is OK,
then I get the normal message "Debug is not enabled in the current configuration. Please start without debugging or change in properties -> iOS Build"

Result : The app is not deployed on device.

Notes :
With same steps, app is deployed OK on simulators.
Also, F5 in debug mode is deploying the app OK.

Thanks for help.

Best Answer


  • JoaquinParraguezJoaquinParraguez USMember
    edited September 2017

    this solved not work for me, i have the same issules, but i create 2 cert. ad hoc and store in the web page apple, but the message still the same. please help me.
    iPhone SE iOS 9.3.2 and iPhone 4 iOS 7.0.1
    Mac OS 10.12.6
    Xcode 8.3.3
    Visual Studio 2013
    Xamarin for visual studio 4.5

    "Deploy failed. The app 'AppAmipassSociosiOS' could not be deployed to the device 'iPhone SE'. Error: error MT1001: Could not find an application at the specified directory: /Users/casa/Library/Caches/Xamarin/mtbs/builds/AppAmipassSociosiOS/08c809e29dd50bfbdd7db7244a891650/bin/iPhone/AppStore/"

    Thanks for help.

Sign In or Register to comment.