Could not find file obj/iPhoneSimulator\Debug\xxxxxx.exe.manifest

swoswo USMember ✭✭

Hi
Today I Installed Xamarin iOS Simulator (for Windows) . When I start debug (Debug - IPhoneSimulator - IPhone 5s iOS 9.3) i get following message now:
Could not find file obj/iPhoneSimulator\Debug\xxxxxx.exe.manifest.

There is no manifest file in the directory. How can i force VS to create one ? When I disable remote Simulator on Windows i get the same error now.

Setup
VS 14.0.25425.01 Update 3
Xamarin 4.1.2.18
Xamarin.IOS 9.8.2.22
Xamarin.Forms 2.3.0.107

Best Answer

Answers

  • tjismhtjismh USMember ✭✭

    Hi
    Did you ever resolve this issue? I have started experiencing it today and can't get my project to build.

  • i also getting this issue but i cant resolve it

  • i just try it but not working

  • DaveHurtDaveHurt USMember

    Disabling ClickOnce security settings worekd for me. Thanks!

  • BobMcLellandBobMcLelland USMember ✭✭

    I too installed the iOS simulator and ran into issues. Getting the same message regarding the iPhone Simulator....

    Could not find file obj/iPhoneSimulator\Debug\xxxxxx.exe.manifest

    I'm running Visual Studio 2015 and have everything configured to where it's working. Visual Studio communicates with the Mac and I can see the simulator on the Mac and step through the code in VS.

    Disabling ClickOnce did get me a little closer; the simulator did launch but was stuck with the word "Updating...." on the iPhone simulator screen. After 10 minutes I killed it and abandoned the endeavor. I'll wait until a release version comes out.

    The installation package version I used is ......

    Xamarin.Simulator.Installer.0.10.0.6.msi

  • SuatKorkmazSuatKorkmaz USMember ✭✭✭

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it

    Worked for me. Thanks.

  • praveenaHMpraveenaHM USMember ✭✭

    hi Suat Korkmaz,
    Worked for me also. Thanks.

  • souravbaratsouravbarat USMember

    Disabling ClickOnce security settings worekd for me. Thanks a lot https://forums.xamarin.com/profile/235975/swo

  • jtaylorjtaylor USMember

    Worked for me too. Thanks!

  • RefatZakyRefatZaky USMember

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it

    worked for me

  • Good, but Was anyone able to get a successful publish/deploy? - I noticed when you switch off (disable) Project settings => Security => Enable ClickOnce security settings, it automatically re-selects itself when you attempt to publish the iOS project.

  • DominikMDominikM DEMember ✭✭

    For those of you which got the same problem and can't fix it.
    Try to revert your changes (hopefully you used TFS/SVN/GIT...).

    I can only say how i ended in this misery, i have tried to publish my iOS app and started to use any publish option in Visual Studio 2015... .
    After this it seems that windows created some dependency and wants any manifest....

    My fix was to revert the changes....

    Hope it could helps somebody

  • AnilAkzmAnilAkzm USMember

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it
    Worked for me. Kind Rigards.

  • Jigar_rughaniJigar_rughani INMember

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it

    worked for me ....Great

  • Jigar_rughaniJigar_rughani INMember

    Thanks

  • MounesSahibMounesSahib USMember ✭✭

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it

    ....That's worked with me .... but i am wondering why is this under severity security settings while it is all about file not found exception..
    thanks again man...

  • NeocomerNeocomer GBMember ✭✭

    @MatthewJames.3180 said:
    Good, but Was anyone able to get a successful publish/deploy? - I noticed when you switch off (disable) Project settings => Security => Enable ClickOnce security settings, it automatically re-selects itself when you attempt to publish the iOS project.

    Getting this error, has anyone got a fix for this, I'm about to just go android only at this rate

  • EternalBardEternalBard BRBeta ✭✭

    Same thing here. Until yesterday morning all was run OK. Then, hours later after testing Android version, no iOS version run again, debug or release version.... More 8 hours lost and counting just to publish a version of my app for testers.

  • GreigFieldsGreigFields USMember

    @swo said:
    What I remember , (but I am not sure) try to switch off IOs Project settings => Security => Enable ClickOnce security settings => disable it

    Worked today for me also.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @MatthewJames.3180 said:
    Good, but Was anyone able to get a successful publish/deploy? - I noticed when you switch off (disable) Project settings => Security => Enable ClickOnce security settings, it automatically re-selects itself when you attempt to publish the iOS project.

    I only see that option being automatically set if I use the "Publish" menu item, either right-click on project in solution explorer and select "Publish" or use the "Build->Publish ProjName" menu. But you should not use this publish workflow for iOS apps. See our docs on publishing your Xam.iOS app:
    https://developer.xamarin.com/guides/ios/deployment,_testing,_and_metrics/app_distribution/

  • YogeshhJunejaYogeshhJuneja INMember ✭✭

    I am very new to xamarin please tell me how to Disabled ClickOnce step by step

Sign In or Register to comment.