System.Net.WebException Error: NameResolutionFailure



  • VenkatXamarinVenkatXamarin INMember

    I'm having this issue ? Do we have any resolution for this ?
    I tried to access a service from Xamarin.Android application both on real device ( API 19 ) and emulator ( Nexus S API 23 - x86 ).

    In both the cases , i'm getting the same "Name Resolution Error."
    Any help is appreciated ?

  • I have this issue as well when I build in Release Mode on multiple WLAN's all without a proxy. In Debug it works fine. Also I have set the Internet Permission. Linking is set to None.
    Any Solution here?

  • could you please provide solution how to handle in client side using code

  • tschennietschennie USMember ✭✭

    I solved it also by setting permission for INTERNET within the Android-Manifest

  • imadhatimiimadhatimi USMember ✭✭

    Go to Properties -> Android Build -> General
    HttpClient Implementation - AndroidClientHandler
    SSL/TLS implementation - Native TLS 1.2+
    Working for me.


  • EldlabsEldlabs Member

    Just switch to orio 8.x emulator it worked for me.

Sign In or Register to comment.