Could not load file or assembly Xamarin.UITest.Shared

donnibdonnib DKMember ✭✭

Hi,
I am trying to setup a test using UITest, NUnit and Specflow, i've had it to before but then i did an upgrade on Xamarin (latest on stable as of 10th July 2016) and now i am getting this weird error. I don't believe i have changed anything since i've seen it work:

I am running :

Xamarin.UITest - 1.3.14-1509-dev
SpecFlow - 1.9.0
Specflow.NUnit - 1.1.1
NUnit - 2.6.4

The app has Calabash running fine in it since the Xamarin TestRecorder works fine on it. As soon as i start the test the simulator launches then the app launches then bang the crash below, i have spent many hours to try figuring out what might be the problem but so far i have not solve it, any ideas what the cause could be ?

SetUp : System.Reflection.TargetInvocationException : Exception has been thrown by the target of an invocation.
----> System.IO.FileNotFoundException : Could not load file or assembly 'Xamarin.UITest.Shared, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

I have tried to remove all NUGet and references then add all of them again in hope something went wrong in the references since the error indicates it can't find an assembly.

Posts

  • PeterMajorPeterMajor GBUniversity ✭✭

    Yes I'm also getting the same error after I upgraded today

  • donnibdonnib DKMember ✭✭

    @PeterMajor that sounds bad but good in the way that i am not the only one so it's not something specific to me. I guess we should send a bug report to Xamarin with this unless somebody from Xamarin creates a bug on this. I could hope there was some kind of a workaround.

  • JimBennettJimBennett GBXamarin Team, Insider, University, Developer Group Leader ✭✭✭✭

    I got round it by downgrading to 1.3.12

  • donnibdonnib DKMember ✭✭

    @JimBennett thx a bunch, that solved it.

  • DavidLavenderDavidLavender GBXamarin Team Xamurai

    Thanks for reporting the issue.

    This issue will be resolved in 1.3.15 which will be released later today. Let me know in this post if you face any further issues.

    The fix is also available in dev build 1.3.14.1513-dev.

  • donnibdonnib DKMember ✭✭

    @DavidLavender I tried version 1.3.15 and yes the issue is fixed now, thank you.

Sign In or Register to comment.