Objective Sharpie 3.3

abockabock USXamarin Team, Insider Xamurai
edited October 11 in Objective Sharpie

Objective Sharpie 3.3 supports Xcode 8 Beta 4 and its updated iOS, macOS, watchOS and tvOS SDKs, and has a few small fixes.

The version of Clang that powers Objective Sharpie is now updated to the latest and greatest as well.

Notable Fixes

Posts

  • kodejackkodejack GBUniversity ✭✭
    edited June 19

    Hi,

    I'm trying to bind the PayPalHereSDK.framework using objectsharpie 3.3.

    It looks like the paths have changed in Xcode 8.3.3.

    Xcode is installed in the default location and objective sharpie is looking for the iphoneOS includes and SDKs in non-existent locations.

    Commands

    Here are the commands I have tried using:

    sharpie bind -verbose -sdk iPhoneOS10.3 PayPalHereSDK.framework/Headers/PayPalHereSDK.h -scope PayPalHereSDK.framework/Headers -c -F PayPalHereSDK.framework
    
    

    and

    sharpie bind -verbose -sdk iPhoneOS10.3 -framework PayPalHereSDK.framework
    

    Both give the same result.

    clang -cc1 version 4.0.0 based upon LLVM 4.0.0git default target x86_64-apple-darwin16.6.0
    ignoring nonexistent directory "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.3.sdk/usr/local/include"
    ignoring nonexistent directory "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.3.sdk/Library/Frameworks"
    
    

    The files objectivesharpie/ clang is looking for are located in the following locations on my mac (iPhoneOS10.3.sdk is an alias to iPhoneOS.sdk):

    Headers

    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/include
    

    Frameworks

    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/System/Library/Frameworks
    

    This I believe is causing the following error, as it is unable to find a CGSize

    ./PayPalHereSDK.framework/Headers/PPHCardReaderDisplayScreen.h:29:33: error: unknown type name 'CGSize'
    @property (nonatomic, readonly) CGSize resolutionDimensions;
    

    Is there a way to change where it finds the native headers and SDKS or is there any other way to fix this?

    Any help here much appreciated

    Gordon

This discussion has been closed.