Windows 8.1 HAXM Android Emulator

ChristopherCrawfordChristopherCrawford USMember
edited July 2016 in Xamarin.Android

Hello

Recently I noticed while ramping up another teammate that the Xamarin Android Player has been deprecated. In trying to set up the HAXM accelerated emulator, I ran into some issues. I followed this guide (https://developer.xamarin.com/guides/android/getting_started/installation/accelerating_android_emulators/) and was able to actually launch the intel atom emulator. However, the emulator is prohibitively slow and never leaves the "Android" load screen (animation slowly moves but goes on indefinitely) When launching the emulator, here is the output I see:

... Hax is enabled Hax ram_size 0x80000000 HAX is working and emulator runs in fast virt mode. console on port 5554, ADB on port 5555

I would assume that this means that HAX has been installed correctly. I have downloaded it from the intel page mentioned previously and installed successfully. That being said, I'm running Windows 8.1 and noted the hotfix listed there as well. When clicking that link, intel redirects to the same download page as the regular install.

So one of two things are the problem. If intel has now included the win8.1 hotfix in that download, then something is wrong with my setup (I believe I installed every intel atom image from the SDK manager and the intel haxm package from Extras). If intel has not included that hotfix in that download, then the missing hotfix is obviously the issue. If that's the case, does anyone know where that hotfix is? Any information would be appreciated.

Sign In or Register to comment.