Android tools in VisualStudio 2015 is disabled.

DimChrisDimChris USMember ✭✭✭

I cant' remember if i did something but my android toolsin Virual Studio 2015 is disabled. How can i fix this?!
Image

Best Answer

Answers

  • Here you can find answer
    http://stackoverflow.com/questions/24949446/android-bat-file-is-missing-in-sdk-tools-folder-also-i-do-not-having-avd-sdk-m

    Probably all the contents of the sdk/tools folder are missing as well?

    Best method to solve this issue is to go to the sdk/temp folder. There you will find a zip file with a name like "tools_r24.0.1-windows" (version number will be different)

    Copy it to someplace and extract it. Inside the extracted folder you'll have a folder named 'tools'

    Copy that folder to sdk/ and replace the current tools folder in sdk/

    And voila! SDK and AVD will work again and all your virtual devices will be restored!

  • MayFlowerMayFlower USUniversity

    Thanks Albert, refresh your solution clean install latest VS2015 helped me too, other approach such as patching Android component didn't solve the issue for me.

  • AbdulbashaAbdulbasha USMember ✭✭

    Your JDK and Android NDK Locations paths might be properly set but SDK might be not set. Even i had the same problem. I solved it in three steps . If you have the same problem as shown above Image,then follow these steps.
    1. Click on Change, it will show Folders.
    2. Select this Path ****C:\Program Files (x86)\Android\android-sdk****
    For all the systems, the SDK will be located in this location only.
    3. Click on Ok. now your Android SDk manager will be in Enable. Your Problem will solve.

    Incase your android-sdk not located in this place, then you need to search for android-sdk where it is located.
    If you dont find android-sdk in C Drive, it may not be installed properly.
    Here we have two Options.
    1. Open vstoolsforxamarin.exe and select the tools which we need and update them (or)
    2. You can install android-sdk manually
    here is the link https://developer.xamarin.com/guides/android/getting_started/installation/windows/manual_installation/.

    My suggestions is dont Uninstall and install VS, its unnecessary headache

  • tinkuestinkues INMember

    Thanks ShakizatAlmenov.4342, after extracting the zip file in C:\Program Files (x86)\Android\android-sdk\temp
    and copy the tools folder and overwrite the existing tools folder, the AVD manager work fine, without reinstalling the visual studio....

  • I had very strange behavior of my Visual Studio: when I just launch it Android tools was shown but after loading a solution it dissapear. All settings was OK. What is interesting: my app perfectly build and start on my devices, but i could not archive and distribute it because of hidden buttons.
    I resolved this by changing android-sdk path:
    C:\Program Files (x86)\Android\android-sdk
    to this:
    C:\Users\{username}\AppData\Local\Android\sdk

    Perhaps it will help somebody

Sign In or Register to comment.