Forum Xamarin.Android

Android "No resource found" for dependencies after adding Drawable folders

GuidoKerstenGuidoKersten NLUniversity ✭✭

I've added multiple dependency libraries to my project. This project was building fine until I decided that I wanted to add Drawable for different screenresolutions. So, I added the drawable-hdpi, drawable-xhdpi, etc. But now, when I try to build the app, I get 136 errors saying that I am missing resources, which were not missing before.

Just to give you a few of those errors:

Reference to HockeyApp SDK:
No resource found that matches the given name (at 'background' with value '@drawable/hockeyapp_btn_background'). (APT0000)

Reference to Meridian SDK (Binding Project):
No resource found that matches the given name (at 'src' with value '@drawable/mr_ic_action_arrow_left'). (APT0000)

But also multiple of these abc_:
No resource found that matches the given name (at 'drawable' with value '@drawable/abc_list_selector_disabled_holo_dark'). (APT0000)
No resource found that matches the given name (at 'drawable' with value '@drawable/abc_btn_rating_star_off_mtrl_alpha'). (APT0000)

Other usefull info:
I'm using: Xamarin.Forms (2.3.0.107)
Xamarin.Android.Support.v4 (23.3.0)
Xamarin.Android.Support.v7 (23.3.0)
Xamarin.Android.Support.v8.RenderScript (23.3.0)

Building against:
Minimum Android version: API level 15
Target Android version: Automatic (API 23)

Any idea what could be wrong?

Answers

  • I'm seeing the same thing. Did you find a fix? Sometimes the problem goes away after cleaning, restarting Xamarin Studio, and building again, but not reliably.

  • I found a fix. In my case it turned out that all of these error messages were just horribly misleading fall out errors from my original problem.

    Somehow a few images I added to my Android project got corrupted and were interrupting the resources step of the build process. Once I replaced those everything built again.

Sign In or Register to comment.