Xamarin.Forms 2.3.1-stable

13»

Posts

  • RodrigoEliasRodrigoElias USMember

    Hi pals,

    ListView's GroupHeaderTemplate seems to be broken on Android when using a DataTemplateSelector.

    This doesn't seem to be related to v2.3.1 since I downgraded XF to 2.2.0 and it still breaks.

    I've added to the bugzilla here: https://bugzilla.xamarin.com/show_bug.cgi?id=43710

  • scottrsimmsscottrsimms AUMember
  • JohnHardmanJohnHardman GBUniversity ✭✭✭✭✭
    edited August 2016

    @BryanHunterXam

    I am still seeing the one pixel gap on Android after upgrading to 2.3.1.114 . Can this be re-opened, or shall I raise a new bug?

    I am assuming that I shouldn't need to update any other NuGet packages, other than Xamarin.Forms, to get this to work...

  • MichaelDimoudisMichaelDimoudis AUUniversity ✭✭

    Hi @BryanHunterXam @rmarinho

    On Xamarin Forms 2.3.1.114, the ListView is broken on iOS 10 beta's. Setting ListViewCachingStrategy to RecycleElement freezes the app. No errors occur, app just freezes. Setting ListViewCachingStrategy to RetainElement fixes my simple ListViews.

    However setting ListViewCachingStrategy to RetainElement on a complex ListView that has many DataTemplateSelector's, the app freezes once again.

    Xamarin Forms 2.3.0.107 works on iOS 10 beta without any issues.

    Xamarin Forms 2.3.1.114 on iOS 9 works without any issue.

    So I just resubmitted my app to the iTunes App Store downgrading to Xamarin Forms 2.3.0.107 so when people start updating to iOS 10 my app will work.

    When I have time later on I'm going to try and create a repro solution and submit an official bugzilla. It's a bit hard as NO errors are logged at all.

    Hopefully this is a simple fix prior to iOS 10 been released main stream, cheers :)

  • MichaelDimoudisMichaelDimoudis AUUniversity ✭✭

    Filed a bugzilla for above iOS 10 beta ListView issue here https://bugzilla.xamarin.com/show_bug.cgi?id=43996

  • LesterMeeksLesterMeeks USMember ✭✭

    I have several ListViews that work fine on iOS 10 Beta 8, but one in particular seems to just lock up the display. I guess I should see what else bites me when I try to downgrade to 2.3.0.107 like you. Here's to playing the upgrade lottery!

  • PaulDiPietroPaulDiPietro USXamarin Team Xamurai

    @MichaelDimoudis @LesterMeeks The ListView issue is being looked into and the cause is known. I or someone else will provide updates with any further information as it's available.

  • MiguelCervantesMiguelCervantes MXMember ✭✭✭

    @EmanueleSabetta Man, have you ever seen how to optimize Xamarin Froms Android apps? In my production app I have a wall like listview, I have tested it with 500 hundred elements and its smooth. It only has a profile image but they are rounded.

    Check out FFImageLoading plugin so you can replace all Images within your viewcell with this one and you will see a LOT of performance.

    Its a common known that on Android images are heavy as hell, I was suffering that too, but since I changed to FFImageLoading everything works fine.

    Hope this helps!

  • aizefleraizefler BRUniversity ✭✭

    @ScottSimms, i have same problem, found a solution to solve the problem?

  • scottrsimmsscottrsimms AUMember

    Hi @AlexandreIzefler.8995,

    Please see comments on this here: https://bugzilla.xamarin.com/show_bug.cgi?id=43692

13»
Sign In or Register to comment.