Forum Visual Studio

Cannot debug Android project


I have been working on a Xamarin Forms project for almost 6 months now and the other day I just can't debug on android anymore. The project builds and deploys successfully but Visual Studio prompts this error message:

The debugger was unable to terminate one or more processes:

[N/A] Mono: The debugger is still attaching to the process or the process is not currently executing the type of code selected for debugging.

The debugger may be unstable now. It is recommended that you save all files and exit.

I have tried updating Xamarin tools and Android SDK but still the same. I also tried using different devices and clean installing it but to no avail.
My colleagues at work can build and debug fine on Android.

Has anyone experienced the same thing?

Here are the tools that I'm using:
Windows 10
VS Pro 2013 Version 12.0.40629.00 Update 5

The Xamarin.Forms version I'm using is


  • RohanGanesanRohanGanesan USUniversity

    Having the same issue here - not entirely sure what happened. I was debugging all day and then all the sudden it stopped functioning.

  • hargendaslihargendasli CNMember ✭✭

    Same as what I met. any one know what's going on?

  • penzeslpenzesl Member

    Try to run Visual Studio as admin.

  • PierceBogganPierceBoggan USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Administrator mode is not a requirement. If you're hitting scenarios where it is, or have other problems like this, please report them via Help > Send Feedback > Report a Problem. This is the easiest way to report your issue and get status emails as the team works through the issue.

Sign In or Register to comment.