Portable Library in Xamarin Studio 4.0.12??

Today I was trying to create a Portable Library project and I immediately get a lot of build errors and under options I find this error:

"the .net portable version=4 profile 136 framework is not installed"

Is my installation corrupt or do I need to install something else as well?


Xamarin Studio
Version 4.0.12 (build 3)
Installation UUID: 1595a3dc-a99f-49e4-b529-51e67d8f6559
Runtime:
Mono 3.2.0 ((no/7c7fcc7)
GTK 2.24.20
GTK# (2.12.0.0)
Package version: 302000000

Apple Developer Tools
Xcode 4.6.3 (2068)
Build 4H1503

Xamarin.iOS
Version: 6.4.1.1 (Enterprise Edition)
Hash: 5a0fe54
Branch:
Build date: 2013-30-07 08:24:03-0400

Xamarin.Mac
Xamarin.Mac: Not Installed

Xamarin.Android
Version: 4.8.1 (Enterprise Edition)
Android SDK: /Users/Manne990/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
4.0 (API level 14)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

Build Information
Release ID: 400120003
Git revision: 593d7acb1cb78ceeeb482d5133cf1fe514467e39
Build date: 2013-08-07 20:30:53+0000
Xamarin addins: 25a0858b281923e666b09259ad4746b774e0a873

Operating System
Mac OS X 10.8.4
Darwin mapar.admore.local 12.4.0 Darwin Kernel Version 12.4.0
Wed May 1 17:57:12 PDT 2013
root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64

Posts

  • mhutchmhutch USXamarin Team Xamurai

    We do not yet ship reference assemblies on Mac for the PCL frameworks.

    If you update Mono to 3.2.1 it will build your PCL projects against Xamarin.iOS/Android, which is not technically correct but works well enough in many cases.

  • Manne990Manne990 SEMember

    Thanks!

Sign In or Register to comment.