Regarding Cross Platform app development

PraduPradu Pradnya BabarINMember

Hii,

I have following machine configuration for xamarin,

1) Window 10
2) Visual studio community 2015

when I create cross platform project it shows error for android version error as following
"a problem was encountered creating the sub project'app.droid'. this property is not valid when the sdk is not installed"
When I click on ok button it creates project with following subproject ios, windows phone(8.1), Windows(8.1), UWP . When I build project it builds perfectly. it runs on device. but when I add xaml page. It show error some library files are missing. It also shows error to InitializeComponent();. Please provide me technical requirement so that i can run cross platform app without any error.

Posts

  • ShantimohanElchuriShantimohanElchuri Shantimohan Elchuri USMember ✭✭✭✭

    It seems you don't have Android SDK. In VS go to Tools -> Android -> Android SDK Manager and install all the sdk's needed. It should have been done when you installed VS and selected Cross Platform SDKs. You can also try repairing your VS installation.

  • PraduPradu Pradnya Babar INMember

    Thanks For your reply.

  • PraduPradu Pradnya Babar INMember

    when I build project it shows following warnings,

    1) Severity Code Description Project File Line Suppression State Warning Type universe cannot resolve assembly:
    System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a. App5.UWP

    2) Following Error shows for Android, Windows, Windowsphone, ios

    Severity Code Description Project File Line Suppression State Warning

    IDE0006 Error encountered while loading the project. Some project features, such as full solution analysis for the failed project and projects that depend on it, have been disabled. App5.Windows 1 Active

  • PraduPradu Pradnya Babar INMember

    I really don't understand whether its visual studio problem or anything else I have following technical specifications
    1) visual studio 2015 community
    2) Windows 10

  • AlexisComteAlexisComte Alexis Comte FRMember

    Hi

    seems I have same problem and same configuration

    I have started a new project

    Any help appreciated.

    Alexis

    Cannot resolve Assembly or Windows Metadata file 'System.Runtime.dll'

    Type universe cannot resolve assembly: System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a.

  • PetarPeevPetarPeev Petar Peev USMember

    thank you Jesse Jiang. it works fine for me!

  • rughvi8784rughvi8784 Venkata Vadigepalli GBMember

    thanks you @Jesse_Jiang . That resolved the issue I had.

  • alimaxionalimaxion Alimi Nurudeen USMember

    Thanks Jesse works for me too

  • DevologyDevology Rob Wilson GBMember ✭✭

    Thanks, this worked for me too.

    From Visual studio 2017 RC, go to Tools -> Nuget Package Manager -> Package Manager Console then type

    Install-Package Microsoft.NETCore.UniversalWindowsPlatform

  • StackunderflowsStackunderflows Mike Rampanelli USUniversity ✭✭

    FYI - version 5.3 of UniversalWindowsPlatform was released and it requires VS 2017. If you just install it without specifying the version, you will get the latest and it will not work on VS 2015 or earlier. You need to downgrade to 5.2.2 in order to run on VS 2015.

    Install-Package Microsoft.NETCore.UniversalWindowsPlatform -Version 5.2.2

  • Ron999Ron999 Ron Minnix USMember ✭✭

    unable to get v5.2.2 to work, but ver5.1.0 worked fine

  • RichardMcGoughRichardMcGough Richard McGough USMember

    @Jesse_Jiang said:
    Install "Microsoft.NETCore.UniversalWindowsPlatform" nuget can solve this issue.

    Thanks! I just had to update mine to the latest version and that fixed it for me.

  • ShahidAli.7296ShahidAli.7296 Shahid Ali USMember ✭✭
    edited October 12

    I got Visual studio 2015 installed and updating "Microsoft.NETCore.UniversalWindowsPlatform" wouldn't work so i had to downgrade it to the 5.2.2.

    Unfortunately without any luck !..

Sign In or Register to comment.