Upgraded to Xamarin Studio 4.0.11- Getting compiler errors

I just upgraded to 4.0.11 and built my project

I receive the following errors when I build my project.

I did not get these errors when I built my project with 4.0.10

These files are part of a project that I reference in my main project

Does anyone have any ideas what is causing this?

CSC : error CS2001: Source file 'AESObfuscator.cs' could not be found

CSC : error CS2001: Source file 'DeviceLimiter.cs' could not be found

CSC : error CS2001: Source file 'ILicenseResultListener.cs' could not be found

CSC : error CS2001: Source file 'ILicensingService.cs' could not be found

CSC : error CS2001: Source file 'IPolicy.cs' could not be found

CSC : error CS2001: Source file 'LicenseChecker.cs' could not be found

CSC : error CS2001: Source file 'LicenseCheckerCallback.cs' could not be found

CSC : error CS2001: Source file 'LicenseValidator.cs' could not be found

CSC : error CS2001: Source file 'NullDeviceLimiter.cs' could not be found

CSC : error CS2001: Source file 'Obfuscator.cs' could not be found

CSC : error CS2001: Source file 'PreferenceObfuscator.cs' could not be found

CSC : error CS2001: Source file 'ResponseData.cs' could not be found

CSC : error CS2001: Source file 'ServerManagedPolicy.cs' could not be found

CSC : error CS2001: Source file 'StrictPolicy.cs' could not be found

CSC : error CS2001: Source file 'ValidationException.cs' could not be found

Posts

  • DavidRuchtiDavidRuchti USMember ✭✭

    I did some additional investigating.

    My app is made up of the main project and to other projects named GameLogic and GoogleLVL.

    When I build the main project the build output looks like this. The build for GameLogic is pointing to GoogleLVL and the build for GoogleLVL is pointing to GameLogic.

    Could this be causing the problem? And if so, how do I fix it?

    BUILD OUTPUT

    Building: GameLogic (Debug)
    Build started 8/6/2013 10:57:36 PM.


    Project "C:\Users\druchti\Documents\x\y\GoogleLVL\Unnamed_1" (Build target(s)):

    Building: GoogleLVL (Debug)
    Build started 8/6/2013 10:57:37 PM.


    Project "C:\Users\druchti\Documents\x\y\GameLogic\Unnamed_1" (Build target(s)):

  • DirkWeltzDirkWeltz DEMember ✭✭✭

    Here the same. Yesterday all worked perfect, but now I get also the above errors.

    Any solution?

    Best regrads,
    Dirk

  • WaynePhippsWaynePhipps GBMember
    edited August 2013

    Same here. The only thing I can add is I'm working on two separate projects both for my employer.
    The first for Android 4.3 with no external dependencies builds fine where the second project where LegacyBar is a dependency fails although will build fine on its own.

    This leads me to believe its related to a project dependency for this solution but perhaps I'm wrong?

    I really need to roll back to 4.0.10 or I'm screwed as we have a project deadline due but cant find it anywhere.

    Build: 93 errors, 0 warnings :-(

  • WaynePhippsWaynePhipps GBMember
    edited August 2013

    Actually, although it looks like I'm getting similar 'file not found' errors as the OP, I've since noticed the error msg is different and mostly like the following:
    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(566,2): error MSB3030: Could not copy the file "Resources\values\integers.xml" because it was not found

    Also, in this example, they appear to solely be related to resource files in the dependent project and not source files as in the example of the OP.

    Seemed related IE both 4.0.11, file not found errors and both sound like they include a dependent project just don't want to hijack this thread.

  • DaveWrightDaveWright GBMember

    Same problem here. Any ideas how to roll back to 4.0.10 appreciated.

  • WaynePhippsWaynePhipps GBMember

    I can't yet tell you how to fix, but I can perhaps save you time saying what hasn't worked so far and perhaps save others some time in doing the same.

    I've de-installed everything and used the Package Installer, unfortunately that just downloaded the latest 4.0.11 again.

    I've also switched to the Beta and Alpha channels doing the updates then a Clean-all before Rebuilding each time, unfortunately got exactly the same errors.

  • TobiasKriegTobiasKrieg DEMember

    Same here, but just when i compile it the first time. If i try it a second (maybe a third) time directly after the first try, it works. I know its ugly, but at least i can work now.

  • WaynePhippsWaynePhipps GBMember

    OK, I've managed to recover from this but only by de-installing Xamarin Studio and re-installing from the original MSI.

    Don't laugh but it's now building on v 4.0.1 in both Debug and Release modes.
    Checked for updates but it wants to upgrade back to 4.0.11 and there's no way in hell I'm doing that!

    I got in a 6:30am for an early start, wasted over 3hrs now need to catch up.

  • DaveWrightDaveWright GBMember

    If anyone from Xamarin is watching, I'm getting loads of errors from Xamarin.Android.Common.targets.

  • WaynePhippsWaynePhipps GBMember
    edited August 2013

    I think (although now cant be certain) that I tried re-compiling and don't think it made any difference.

    The reason I'm now unsure is that I cant swear that I didn't do a clean between builds. Perhaps you could test the re-build theory Dave?

    If not, if its anything like their chat times, Xamarin won't be awake for another 4 hours ( 9am - 4pm EDT ) which is 2pm BST.

    If you cant wait, I could probably dropbox you the 4.0.1 installer? I know it's harsh but it got me running again although I'm now screwed if I need to build my other Android 4.3 project again.

  • I got similar, mostly about layout files not found.
    My workaround for that problem was to add and remove a new layout file which triggered some kind of compilation.
    But once I delete the bin and obj directories the problems are back.

  • DaveWrightDaveWright GBMember

    I found a small difference between release and debug builds (sometimes working, sometimes not), but I have four libraries in my project and didn't get them to all build at any point. If you could post a link to 4.0.1 that would be excellent.

  • constructorconstructor GBMember

    After update I can no longer build my projects. This is wasting so much time. How was this allowed be pushed as an update? Anyone got a link to the previous 4.0.1? I have already lost one late night and now a morning.

  • constructorconstructor GBMember

    Thanks for the link Wayne. I have installed and all is working again. I can now try and catch up for all my lost time.

  • DaveWrightDaveWright GBMember

    Woohoo! Up and running again. Thanks very much Wayne. The moral of the story seems to be: Don't update Xamarin in the morning (BST). Or perhaps at all on the day when it first pops up...

  • i got the same problem. any solutions please advise. thanks

  • WaynePhippsWaynePhipps GBMember

    That sounds about right, the last update gave me problems although there was a fix on the Beta channel after a few days. I hoped that experience was a one-off, I won't be upgrading so flippantly next time.

  • MartindeJongMartindeJong NLMember

    Me too :(. Still i can build in Visual Studio 2010. Have a problem with datacontract serialization now too.

  • Xamarin can you help us solving this problem ?! My organization is stopped because nobody can build project with 4.0.11 update. Please give us a sign !

  • constructorconstructor GBMember
    edited August 2013

    Stefano, the only way we could continue was to install the previous version. I agree with your sentiment. Xamarin should give us a sign :) Look above for the link.

  • RyanEstevesRyanEsteves USMember, University

    Getting build errors here as well. Referenced library projects are coming up with missing file errors.

  • Tom_at_GsnTom_at_Gsn USMember

    Can we get a Mac Os X download link for 4.0.1+ (anything but 4.0.11)

    Ugh

  • amilleramiller USXamarin Team Xamurai

    Hi @Tom_at_Gsn!

    If you write into [email protected] we can provide you with the downgrade file for Mac OSX :)

  • mhutchmhutch USMember, Xamarin Team Xamurai

    We've identified the issue that caused certain MSBuild-based projects to failed to build with Xamarin Studio 4.0.11 and we are preparing a Xamarin Studio hotfix release.

  • poolempoolem USMember

    This issue also affects you demo projects.
    I am evaluating Xamarin as a mobile development platform and am unable to compile your Tasky project.
    Shall I evaluate Xamarin at a later date? When?

    Thank you

  • Any idea when the hotfix will be available? Would it be worthwhile to move to a previous release?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    It should be available within the next few days.

  • RonMacedoRonMacedo USMember

    I uninstalled the latest version and installed the Xamarin Studio 4.0.1 and now I'm back up and running (Thanks Wayne). Now I will also try to recoup lost time since we have a deadline coming up.

  • DavidRuchtiDavidRuchti USMember ✭✭

    I downloaded and installed 4.0.12. I am now able to get a clean compile. Thank you Xamarin.

  • DirkWeltzDirkWeltz DEMember ✭✭✭

    Here it is working with 4.0.12 also. Thank you.

  • NoGlassHouseNoGlassHouse USMember

    Nice to hear (was not affected of the unable-to-open-project-bug), hopefully the next hotfix will cover the other evil bug that prevents adding of webservice proxies while svn plugins are enabled :)

  • eusebiumeusebium ROMember ✭✭
    edited August 2013

    I've installed the latest update on Xamarin Studio (4.1.9 build 6) and I still get this kind of error.
    I've also found some "workaround" by modifying an axml file (Xamarin.Android) (i.e. adding a space after an attribute) and then build/deploy... But it does not work always... :)

  • PJBeamanXPJBeamanX USXamarin Team Xamurai

    Hi all,

    The 4.0.12 update will fix this issue. Here is a direct link to the download:

    http://download.xamarin.com/studio/Windows/XamarinStudio-4.0.12-3.msi

    The build is available in the beta channel and will be available in the stable channel shortly.

    Please let us know if you are still experiencing issues after this hotfix, and thank you very much for your patience. Sorry for the inconvenience caused.

    PJ

  • Using version 4.2.3. Getting error:
    C:\Working\git\cfactor\Mobile\cfactor\cfactor.Android\CSC: Error CS2001: Source file '..\cfactor.Core\obj\iPhone\Debug.NETFramework,Version=v4.0.AssemblyAttribute.cs' could not be found (CS2001) (cfactor.Android)

    please help.

    Thanks!
    Ashik

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @KaziAshikAhmed.9925 that sounds like a very different issue. I suggest you open a new topic in the Android forum and include the full build log.

Sign In or Register to comment.