Insights.Report gives a "null" message in the Dashboard

Liger_JeromeLiger_Jerome FRUniversity ✭✭
edited May 2016 in Xamarin Insights

Hello everyone !

I have a strange issue with my Insights dashboard. I have an Android app, and I use Insights to report exceptions that occurs. I hope someone can help me, because i have no idea of what is happening.

It was working fine until yesterday.
Since yesterday, the dashboard shows the Exception name and a "null" message, see on the picture attached.

Usually, the "null" is replaced by the Exception.message, and all other additional information added.

Here is my sample code. I tried several methods but I always get the same result : a "null" message as shown in picture attached.
I would expect to have the message "Will you work ?!" instead of "null"..

`
Insights.Initialize("my_insights_api_key", Context);

            Insights.Report(new Exception("Will you work ?!"), Insights.Severity.Error);


            Exception e = new Exception("Will you work ?!");
            e.Data["AccountType"] = "standard";
            Insights.Report(e, Insights.Severity.Error);


            Dictionary<string, string> dic = new Dictionary<string, string> { { "key", "value" } };
            Insights.Report(new Exception("message"), dic, Insights.Severity.Error);

`

I tried to uninstall and reinstall the nuget package Xamarin.Insights, but nothing changes.
Is there an option in Insights that would has been changed or something like that ?
If anybody has an idea, I would be grateful !

Thanks !

Posts

  • Liger_JeromeLiger_Jerome FRUniversity ✭✭

    OK, after a few hours of search, I rolled back from Xamarin.Insights V1.12.3 to V1.10.4.112.
    Now it works fine.

    I do not anderstand what is the problem, so I think I will work with the old version, and never update again my nuget package :neutral:

    If anybody had the same issue with Xamarin.Insigths V1.12.3, please let me know how you did to get successful.

  • GordAllottGordAllott GBXamarin Team Xamurai
    edited May 2016

    Hi,

    its a rather strange issue you are having, could you try V1.11.4 as well?

  • LeonardDeutschLeonardDeutsch DEMember

    Same problem since yesterday.. seems to have worked with Debug mode - now in the published app it only shows null for stack trace :/ image

  • NikiNiki BGMember ✭✭✭

    I have the same issue - posted about it a while back (http://forums.xamarin.com/discussion/65235/stacktrace-is-null-on-android#latest). I thought it was caused by XS6.0, but will try downgrading the insights package to see if it goes away.

  • RezaMousaviRezaMousavi GBMember

    Same issue here, and I can confirm that 1.11.4 does work fine.

  • LeonardDeutschLeonardDeutsch DEMember

    The last few days I played around a bit and it always seems to correctly send stack traces in Debug mode but not in Release mode. Maybe some part of the Insights assembly is being optimized incorrectly.. Didn't have enough time to research the problem further unfortunately, now I'm back on 1.11.4 and everythings works as expected.

  • Liger_JeromeLiger_Jerome FRUniversity ✭✭

    Hi everyone,

    Thank you @GordAllott for your answer.
    I tried with Xamarin.Insight V1.11.4, and it works fine.

  • @IanJanicki @GordAllott wow you guys really care about the product right? Since 4 month a not working version online? Can that really be true?

  • TejasViswanathTejasViswanath USUniversity

    Really guys?

    We're paying for this you know ...

    @GordAllott

  • batmacibatmaci DEMember ✭✭✭✭

    it seems even today it is the problem. Could this be problem with Linking or Proguard?

Sign In or Register to comment.