Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Lig

AlexanderDAlexanderD USMember
edited May 2016 in Xamarin.Android

I am using visual studio 2015 and getting the following error:

Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'.
-styles.xml

Here are the screenshots of my config

I was previously targeting Android 4.4 but since it didn't work I tried also with 6.0.

C:\Users\Username\AppData\Local\Xamarin is clear, project has been rebuilt several times.

I have been trying

Theme.AppCompat.Light
@style/Theme.AppCompat.Light
@android:style/Theme.AppCompat.Light

The code throwing the error:

style name="MyTheme.Base" parent="Theme.AppCompat.Light"
/style

Tagged:

Posts

  • SHIVANKUCHAUHANSHIVANKUCHAUHAN USMember ✭✭✭

    Your compile SDK version must match the support library's major version.

    Since you are using version 23 of the support library, you need to compile against version 23 of the Android SDK.

    Alternatively you can continue compiling against version 22 of the Android SDK by switching to the latest support library v22.

  • AlexanderDAlexanderD USMember

    Yeah, I've already read that answer on another post and that's why I'm targeting now Marshmallow (API Level 23) with the Android Support Library v23.

    I have a doubt though, is the api level the same as the Andoid SDK?
    If not, where can I change the Android SDK version I am compiling against in Visual Studio 2015?
    Alternatively, how can I switch the support library version?
    Thank you

  • SHIVANKUCHAUHANSHIVANKUCHAUHAN USMember ✭✭✭

    Yes, you are going right, Visual Studio always points to latest Android SDK libraries, So Whenever you are selecting the target version to Android M, Visual Studio is retrieving it from SDK. Additionally in "compile using SDK version" dropdown pick Android M.

  • MairtinOBriainMairtinOBriain USMember

    I am new to programming and am getting the same error, Im not sure where to place the library. Any suggestions?

  • AlexanderDAlexanderD USMember

    I'm sorry but I never managed to solve this issue, I just had to switch to other stuff and forgot about it.

  • Has anyone found a solution to this problem yet?

    I have the exact same error and cannot find a working solution online.

Sign In or Register to comment.