Forum Xamarin.iOS

Xamarin studio hangs on Bundle Signing

Meher.KasamMeher.Kasam USMember

I'm following the tutorial here: I have the necessary certificates and provisioning profiles downloaded and installed on my Mac. I am able to successfully deploy apps to my iPhone through Xcode. However, when I try to open "iOS Bundle Signing" in Build settings, Xamarin Studio on my Mac simply hangs. This is happening in both version 5.x and 6.x. What might be going wrong?

Best Answer


  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    Hi Meher,

    There might be some information in the logs of Xamarin Studio. Try collecting those from the Help -> Open Log Directory. I am guessing the ide.*.log might be the most useful.

    I've also found a similar post here about keychain causing similar symptoms.

  • Meher.KasamMeher.Kasam USMember

    Unlocking the keychain did not help. Also, in that particular case it looks like they were using a remote build server whereas I am building on my laptop. The logs don't seem to explain anything either. This is what ide.log looks like:

    INFO [2016-05-10 14:22:31Z]: ANDROID: Got new device list from adb with 0 devices
    WARNING [2016-05-10 14:22:34Z]: Subversion addin could not load libsvn_client, so it will be disabled.
    Simulator configuration written to /var/folders/sp/dpxp0md55ydgwdsmhqnb4zc80000gn/T/tmp710fc27e.tmp
    INFO [2016-05-10 14:22:35Z]: Add-in loaded: MonoDevelop.HexEditor
    INFO [2016-05-10 14:22:36Z]: Add-in loaded: MonoDevelop.Debugger.Soft.AspNet
    INFO [2016-05-10 14:22:37Z]: Read license: Mac Community
    INFO [2016-05-10 14:22:37Z]: Read license: Mac Community
    INFO [2016-05-10 14:22:38Z]: Add-in loaded: MonoDevelop.ILAsmBinding

    Side note: Today I tried to replicate my setup on a Mac Mini. I am able to successfully deploy to my iPhone using the same certificate and provisioning profile from Xamarin Studio beta. In light of that, I uninstalled and reinstalled all Xamarin components on my MacBook but to no success. How can I debug this issue?

  • Meher.KasamMeher.Kasam USMember

    I've been blocked on this issue for several days now. Can I ask for a quicker turnaround please?

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    Hi Meher,

    Send an email to [email protected] with the IDE log file. Also, include the version information from Xamarin Studio -> About Xamarin Studio -> Show Details -> Copy Information.

    Also, check the on your Mac while this happens and capture any interesting output that might appear in there from Xcode/System/Xamarin Studio.

  • sunfishsunfish USMember ✭✭
    edited November 2016

    Thank you @Meher.Kasam for sharing your first solution - worked for me! I was really stuck on this...

  • Narender_ReddyNarender_Reddy USMember ✭✭

    Thank you @Meher Kasam. Thanks for sharing this. It really saved my day!

Sign In or Register to comment.