I was very confused by the upcoming AzureDataSource feature.
First, the name is too generic. Azure supports many types of data:
So, I took a look at the source code on GitHub and I finally figured out that it is a DataSource for Azure Mobile Services.
As such, I think "MobileServices" should appear either in the namespace or in the classes names.
Would you please rename it and make things clearer?
This is also important in the event that you (or a fork) decide to implement a DataSource for another type of (client-side) data from Azure.
Edit: By the way, I understand that the other data types on Azure are server-side and wouldn't be accessed directly from a mobile app. The name remains confusing regardless.