After upgrading Xamarin to version 4.1.0.313 getting error while building iOS project in VS2015

I have upgraded Xamarin version 4.1.0.313 and also upgraded my MAC Xamarin Studio version, now successfully able to connect mac Agent but when I run my iOS application below build error is displayed in Visual Studio 2015

This version of Xamarin.iOS requires the iOS 9.3 SDK (shipped with Xcode 7.3) when the managed linker is disabled. Either upgrade Xcode, or enable the managed linker.

Please suggest me solution

Best Answer

Answers

  • Thanks Shantimohan upgrading Xcode and iOS to latest version resolved my issue

  • AndreasReiffAndreasReiff DEUniversity ✭✭

    @RenugaMohan
    Option now is called "Link SDK assemblies only".
    Build complained and said I should enable "Managed Linker", but that option is not described anywhere.
    Thanks a lot, looks like iOS development with Yosemite is not possible without your hint.

  • TnagTnag USMember ✭✭

    Thanks @RenugaMohan! You saved me a few hours :)

  • Anyone know how to enable the managed linker in Visual Studio?

  • @StephenHarris said:
    Anyone know how to enable the managed linker in Visual Studio?

    Right click the iOS project -> Properties -> iOS Build -> General tab -> Linker Options

  • Much appreciated, thanks MiloradStevanovic!

  • Got the same error, but even after changing the Linker option to -> Link SDK Assemblies I am getting error.

    Screenshot of the error message attached.
    Please help in resolving the error.
    I am running iOS 10.11.6
    iOS SDK - 10.0
    Xamarin Studio - 6.1.3.19

    Windows machine configuration - Visual Studio 2015 update 3

  • pallavboharapallavbohara USMember ✭✭
    edited February 2017


    Me too getting this error :(

  • pallavboharapallavbohara USMember ✭✭

    This configuration solved error :)

  • MohamedElhefnawyMohamedElhefnawy USMember ✭✭
    edited March 2017

    This version of Xamarin.iOS requires the iOS 10.3 SDK (shipped with Xcode 8.3) when the managed linker is disabled
    same issue can be solved using this steps for who used Visual Studio 2015
    Right click the iOS project -> Properties -> iOS Build -> General tab -> Linker Options
    For Visual Studio 2017 users, may this article can be useful
    pleasure colleagues

  • sumitsisodia.9614sumitsisodia.9614 USMember ✭✭

    Thanks Renuga Mohan its working .

  • patrickmzpatrickmz USMember ✭✭

    I don't understand after updating xamarin all the time 100 errors show !!

  • MounesSahibMounesSahib USMember ✭✭

    Correct ... That really works if you still have the problem after updating to iOS 11.1 with Xcode 9.
    thanks a lot,

    @RenugaMohan said:
    Another option would be to choose to 'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only

  • MounesSahibMounesSahib USMember ✭✭

    @patrickmzaaber said:
    I don't understand after updating xamarin all the time 100 errors show !!

    post those errors...

  • venuszabihivenuszabihi USMember ✭✭

    @RenugaMohan said:
    Another option would be to choose to 'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only

    Thank you so much RenugaMohan! it`s very useful!

  • @RishabhWalia.0852 said:
    Thanx @RenugaMohan, its really working for me

    Choose to 'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only

    it gives me another error "Unexpected error"

  • judsonabrahamjudsonabraham USMember ✭✭✭
    edited June 2018

    @RenugaMohan said:
    Another option would be to choose to 'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only

    I get this error Failed to resolve "Android.App.Activity" reference from "Mono.Android, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065" when I Build after I set to Link Framework SDKs only.

  • jaspervanmjaspervanm Member

    @judsonabraham I am having the same issue. How did you resolve this?

  • judsonabrahamjudsonabraham USMember ✭✭✭

    @jaspervanm I didn't have any option I had to upgrade the xcode8 to xcode 9.

  • jaspervanmjaspervanm Member

    @judsonabraham I made a stupid mistake. Referenced a Android dll in the iOS project..

  • judsonabrahamjudsonabraham USMember ✭✭✭

    @jaspervanm I know that was showing the error but I needed the Android dll for my IOS project.

  • narasimhareddynarasimhareddy USMember ✭✭

    'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only now working

  • anand7Nanand7N Member ✭✭

    Where I can get Xamarin.IOS 10.3 SDK?

  • Thanks so much !!! :)

    @RenugaMohan said:
    Another option would be to choose to 'Link Framework SDKs only' in Project Options->Build->iOS Build->Linker Behavior -> Link Framework SDKs only

  • Thanks @MiloradStevanovic.2147 its working.

Sign In or Register to comment.