Unable to connect to Address='xxx.xxx.xxx.xx' with User='xxxxxx'

Hi guy,

Recently I fall into this issue each time I try to compile my Xamarin iOS app with VS2015 (Update 2) that connected to my Mac machine.

Unable to connect to Address='xxx.xxx.xxx.xx' with User='xxxxxx'

Does anyone have the same problem and any solution to share?

Regards,
CT

Best Answers

Answers

  • PhilippeBourquePhilippeBourque CAUniversity ✭✭

    Same problem here.

    I'm able to go at step 9 here :
    https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/

    But it still impossible to compile anything on iOS.

    Visual Studio 2015 Pro Update 1
    I tried with the actual Alpha, Beta and Stable channel.

  • PhilippeBourquePhilippeBourque CAUniversity ✭✭

    Upgraded to VS 2015 Update 2.
    Same problem.

  • AlexLapointeAlexLapointe USMember ✭✭

    Same problem here, also "Private key is encrypted but passphrase is empty" in Xamarin output.

    I was on beta channel and I put it back to stable. I reinstall my Mac yesterday, stable channel.

    It's connecting, but can't build.

  • AlexLapointeAlexLapointe USMember ✭✭

    I had problem in the past cause the time on my Windows was wrong, but it's not the case now.

  • AlexLapointeAlexLapointe USMember ✭✭

    It's working, thanks

  • CTCHANGCTCHANG AUMember ✭✭

    @MattBrady.9930 said:
    I had the same problem as well. I was able to get it working by embedding the server password in the "Xamarin.iOS.Windows.After.targets" file (replacing the existing ServerPassword variable):

    C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets

    Not ideal but hopefully a fix will be released soon.

    I cannot get it work. May I know the $ServerPassword is refer to which password?

  • MattBrady.9930MattBrady.9930 USMember

    @CTCHANG said:

    @MattBrady.9930 said:
    I had the same problem as well. I was able to get it working by embedding the server password in the "Xamarin.iOS.Windows.After.targets" file (replacing the existing ServerPassword variable):

    C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets

    Not ideal but hopefully a fix will be released soon.

    I cannot get it work. May I know the $ServerPassword is refer to which password?

    $ServerPassword is the Mac build host password.

  • CTCHANGCTCHANG AUMember ✭✭
    edited April 2016

    @MattBrady.9930 said:

    @CTCHANG said:

    @MattBrady.9930 said:
    I had the same problem as well. I was able to get it working by embedding the server password in the "Xamarin.iOS.Windows.After.targets" file (replacing the existing ServerPassword variable):

    C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets

    Not ideal but hopefully a fix will be released soon.

    I cannot get it work. May I know the $ServerPassword is refer to which password?

    $ServerPassword is the Mac build host password.

    I did replaced with my id & password I used to remote in (VNC) into the Mac build host. But no luck.

  • CTCHANGCTCHANG AUMember ✭✭

    @CTCHANG said:

    @MattBrady.9930 said:

    @CTCHANG said:

    @MattBrady.9930 said:
    I had the same problem as well. I was able to get it working by embedding the server password in the "Xamarin.iOS.Windows.After.targets" file (replacing the existing ServerPassword variable):

    C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets

    Not ideal but hopefully a fix will be released soon.

    I cannot get it work. May I know the $ServerPassword is refer to which password?

    $ServerPassword is the Mac build host password.

    I did replaced with my id & password I used to remote in (VNC) into the Mac build host. But no luck.

    Sorry, I did not restart my VS2015. That the reason I did not manage to get it work previously. Now my iOS project is compiling! Thx Matt.

  • PhilippeBourquePhilippeBourque CAUniversity ✭✭

    Switch back to Xamarin 4 and then upgrade again to Xamarin Cycle 6, rebuild couple of time and then it work!

  • CTCHANGCTCHANG AUMember ✭✭

    Brendan, Thx for the update.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Thanks to @MattBrady.9930
    I have started a new .forms project with VS2015 Update 3 RC.
    Initially it has worked - today it has stopped t work for whatever reason.
    I then have hardcodes the password like suggested.
    I don't understand it, but it seems to work...
    To be exact:
    I had to open an editor as administrator
    The open the file (I found it exactly under the path Matt have posted above)
    Then change the line:
    ServerPassword="$(ServerPassword)"
    fill in your password between the ""

  • NBCruzNBCruz USMember ✭✭
    edited August 2016

    Same problem here. It's connected to the Mac - in the Xamarin Mac Agent screen it shows the links signifying that it's connected.

    I checked out the reasons stated here (https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/#Unable_to_connect_to_Address192.168.1.222_with_Usermacuser) but I don't think these two reasons apply as I did not downgrade to 4.0 and it's not showing SSH security message. The build does show these error messages:
    "An attempt was made to access a socket in a way forbidden by its access permissions".

    Tells me it could be a firewall issue.

    When I disable the firewall, it actually builds fine. I created a new rule to allow MSBuild.exe (in C:\Program Files (x86)\MSBuild\14.0\Bin) thru but still no dice.

    In the error message, it actually does not state the port (22), just the IP address of 192.168.1.76
    "Unable to connect to Address='192.168.1.76' with User='macuser'"

    Maybe it needs to be configured to specifically use port 22?

    I'm on VS Pro 2015 Upd 3 and on the Mac XS Community 6.0.2 with Xcode 7.3.1. Both VS and XS are on the same 'Stable' update channel.

  • MarkusSchillerMarkusSchiller DEMember ✭✭

    When I initialy connect to my Mac everything runs. But when my Mac goes to sleep and wakes up again, I get this error in Visual Studio. A reboot of the Mac normally works.

    Is anyone investigating here, or should I open a ticket?

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @MarkusSchiller
    I have this problem, since I work with Xamarin and have disabled the sleep-mode.
    My posting from September 2014 :wink:
    https://forums.xamarin.com/discussion/10130/xamarin-ios-build-host-issue-another-instance-already-connected/p2

    I hoped, that this will change with the new MAC connection software, what unfortunately not seems to be the case...

  • MarkusSchillerMarkusSchiller DEMember ✭✭

    OMG

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    @NBCruz said:

    >

    When I disable the firewall, it actually builds fine. I created a new rule to allow MSBuild.exe (in C:\Program Files (x86)\MSBuild\14.0\Bin) thru but still no dice.

    In the error message, it actually does not state the port (22), just the IP address of 192.168.1.76
    "Unable to connect to Address='192.168.1.76' with User='macuser'"

    Maybe it needs to be configured to specifically use port 22?

    It's not MSBuild that's doing the connecting, it's ssh. By default, ssh uses port 22. So you need to tell your firewall to allow ssh and port 22.

  • NBCruzNBCruz USMember ✭✭

    Fired up VS today and now it's not even connecting anymore. Pings fine from both machines both ways but has the "Couldn't retrieve SSH Fingerprint. Please ensure the Mac is reachable and Remote Login is enabled."

    Remote login is enabled and I've even checked the "Automatically allow signed software to receive incoming connections" box.

    So now I'm on Step 8 of the troubleshooting process (https://developer.xamarin.com/guides/ios/getting_started/installation/windows/connecting-to-mac/troubleshooting/#Troubleshooting_Remote_Login).

    DaveHunt: what SSH client does Xamarin/Visual Studio use to connect and where is the program .exe located? And is this an outgoing or incoming rule in the firewall? I've given VS and MSBuild outgoing permissions to any IP and port.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited August 2016

    where is the program .exe located

    Xamarin for Visual Studio currently uses the SSH.NET SSH library. There is no SSH standalone executable client included with Xamarin. For the purposes of step 8, you can use any Windows SSH client, such as the one packaged in Git for Windows (or you can use any standalone SSH client you like on any other computer on your network, as long as it isn't the Mac build host itself).

    I'm on Step 8 of the troubleshooting process

    Did step 8 fail or succeed? If it failed, see steps 10 and 11.

  • NBCruzNBCruz USMember ✭✭

    Checked out the log and got this:

    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 13:29:40.3396] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.d__1.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.Messaging.FingerprintRetriever.d__2.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\FingerprintRetriever.cs:line 20
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.MacServer.<>c__DisplayClass52_0.<b__0>d.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\MacServer.cs:line 338
    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 14:35:10.8344] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---

    If I turn off the firewall on the Mac, it connects. The firewall on Windows machine is on with outbound port 22 allowed at the Private and Domain scope.

    The Mac is running OS X El Capitan with the lates Xamarin Community Studio and on Windows I have Visual Studio 2015 Update 3, Xamarin 4.1.0.530 and Xamarin.iOS 9.8.0.323

    Is there something else going on with the Mac firewall? I have 'Stealth Mode' on the firewall turned off and checked the "Automatically allow signed software to receive incoming connections" box.

  • NBCruzNBCruz USMember ✭✭

    Checked out the log and got this:

    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 13:29:40.3396] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.d__1.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.Messaging.FingerprintRetriever.d__2.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\FingerprintRetriever.cs:line 20
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.MacServer.<>c__DisplayClass52_0.<b__0>d.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\MacServer.cs:line 338
    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 14:35:10.8344] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---

    If I turn off the firewall on the Mac, it connects. The firewall on Windows machine is on with outbound port 22 allowed at the Private and Domain scope.

    The Mac is running OS X El Capitan with the lates Xamarin Community Studio and on Windows I have Visual Studio 2015 Update 3, Xamarin 4.1.0.530 and Xamarin.iOS 9.8.0.323

    Is there something else going on with the Mac firewall? I have 'Stealth Mode' on the firewall turned off and checked the "Automatically allow signed software to receive incoming connections" box.

  • NBCruzNBCruz USMember ✭✭

    Checked out the log and got this:

    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 13:29:40.3396] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.d__1.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.Messaging.FingerprintRetriever.d__2.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\FingerprintRetriever.cs:line 20
    --- End of stack trace from previous location where exception was thrown ---
    at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
    at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    at Xamarin.VisualStudio.IOS.MacServer.<>c__DisplayClass52_0.<b__0>d.MoveNext() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\Messaging\MacServer.cs:line 338
    Xamarin.VisualStudio.IOS.MacServer Error: 0 : [2016-08-22 14:35:10.8344] Couldn't retrieve fingerprint.
    System.OperationCanceledException: Couldn't retrieve fingerprint. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.76:22
    at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
    at Renci.SshNet.Session.SocketConnect(String host, Int32 port)
    at Renci.SshNet.Session.Connect()
    at Renci.SshNet.BaseClient.Connect()
    at Xamarin.Messaging.Client.Ssh.SshFingerprintRetriever.<>c__DisplayClass2_0.b__1()
    --- End of inner exception stack trace ---

    If I turn off the firewall on the Mac, it connects. The firewall on Windows machine is on with outbound port 22 allowed at the Private and Domain scope.

    The Mac is running OS X El Capitan with the lates Xamarin Community Studio and on Windows I have Visual Studio 2015 Update 3, Xamarin 4.1.0.530 and Xamarin.iOS 9.8.0.323

    Is there something else going on with the Mac firewall? I have 'Stealth Mode' on the firewall turned off and checked the "Automatically allow signed software to receive incoming connections" box.

  • Exelor-DevExelor-Dev CHMember

    Same problem here. Visual Studio has successfully established connection to Mac:
    Starting connection to Mac Cup... Starting Broker 4.2.0.703 in port 53406... Connection successfully established with the Mac Cup:53406 Starting agents on Mac Cup (192.168.11.54) Starting Agent IDB 4.2.0.703... Starting Agent Build 4.2.0.703... Agent Build 4.2.0.703 is running Starting Agent Designer 4.2.0.703... Agent IDB 4.2.0.703 is running Agent Designer 4.2.0.703 is running Connected to the Mac Cup (192.168.11.54) with Full support. Starting connection to Mac Cup... Connection successfully established with the Mac Cup:53406

    But building suddenly breaks with an error:
    ... 2>Using "SayHello" task from assembly "C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.Messaging.Tasks.dll". 2>Task "SayHello" 2> Connecting to Mac server Cup... 2> Starting connection to Mac Cup... 2> Executing SSH command 'whereis xcodebuild'... 2> Executing SSH command '/usr/bin/xcodebuild -license check'... 2> Sending Message Xamarin.Messaging.MessageStatusMessage to topic xma/message-status 2> Sending Request Xamarin.Messaging.GetActiveClientsMessage to topic xma/clients 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : An error occured while deserializing the content of an Application Message for topic build5352weyer/response/xma/clients 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : bei Xamarin.Messaging.Client.ApplicationMessageExtensions.GetContent[T](ApplicationMessage message, IMessagingSerializer serializer) 2> Sending Message Xamarin.Messaging.MessageStatusMessage to topic xma/message-status 2> Received Response of Xamarin.Messaging.GetActiveClientsMessage to topic build5352weyer/response/xma/clients 2> The underlying client has been closed 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): error : Unable to connect to Address='Cup' with User='xxxxx' 2>Done executing task "SayHello" -- FAILED. 2>Done building target "_SayHello" in project "DO-Manager.iOS.csproj" -- FAILED. ...
    I have Visual Studio 2015, version 14.0.24531.01 Update 3, Xamarin 4.2.0.703, and Xamarin.iOS 10.0.1.10 installed.

    I tried deleting the files id_rsa and id_rsa.pub, disconnecting and connecting several times, but it has not worked.

    Does anyone have a solution to this?

  • @Exelor-Dev said:
    Same problem here. Visual Studio has successfully established connection to Mac:
    Starting connection to Mac Cup... Starting Broker 4.2.0.703 in port 53406... Connection successfully established with the Mac Cup:53406 Starting agents on Mac Cup (192.168.11.54) Starting Agent IDB 4.2.0.703... Starting Agent Build 4.2.0.703... Agent Build 4.2.0.703 is running Starting Agent Designer 4.2.0.703... Agent IDB 4.2.0.703 is running Agent Designer 4.2.0.703 is running Connected to the Mac Cup (192.168.11.54) with Full support. Starting connection to Mac Cup... Connection successfully established with the Mac Cup:53406

    But building suddenly breaks with an error:
    ... 2>Using "SayHello" task from assembly "C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.Messaging.Tasks.dll". 2>Task "SayHello" 2> Connecting to Mac server Cup... 2> Starting connection to Mac Cup... 2> Executing SSH command 'whereis xcodebuild'... 2> Executing SSH command '/usr/bin/xcodebuild -license check'... 2> Sending Message Xamarin.Messaging.MessageStatusMessage to topic xma/message-status 2> Sending Request Xamarin.Messaging.GetActiveClientsMessage to topic xma/clients 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : An error occured while deserializing the content of an Application Message for topic build5352weyer/response/xma/clients 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : bei Xamarin.Messaging.Client.ApplicationMessageExtensions.GetContent[T](ApplicationMessage message, IMessagingSerializer serializer) 2> Sending Message Xamarin.Messaging.MessageStatusMessage to topic xma/message-status 2> Received Response of Xamarin.Messaging.GetActiveClientsMessage to topic build5352weyer/response/xma/clients 2> The underlying client has been closed 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): warning : Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. 2>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Windows.After.targets(63,5): error : Unable to connect to Address='Cup' with User='xxxxx' 2>Done executing task "SayHello" -- FAILED. 2>Done building target "_SayHello" in project "DO-Manager.iOS.csproj" -- FAILED. ...
    I have Visual Studio 2015, version 14.0.24531.01 Update 3, Xamarin 4.2.0.703, and Xamarin.iOS 10.0.1.10 installed.

    I tried deleting the files id_rsa and id_rsa.pub, disconnecting and connecting several times, but it has not worked.

    Does anyone have a solution to this?

    Hello,

    I am hitting the same error with 'Done executing task "SayHello" -- FAILED.'

    Were you able to find a work around?

    Thank you

  • SuatKorkmazSuatKorkmaz USMember ✭✭✭

    @BrendanZagaeski said:
    Thanks for the reports. To give a bit more background, one common cause of this issue was "hidden away" on the earlier Xamarin 4.1 release notes without a mention of the exact error message:

    Downgrading or switching channels after installing this version can require deleting files id_rsa and id_rsa.pub from "%localappdata%/Xamarin/Monotouch" to connect successfully with Mac servers using older versions.

    I have now submitted updates for the Xamarin 4.1 and 4.2 release notes to mention the exact "Unable to connect to Address" error message. I have also updated the Connection Troubleshooting guide to include both known causes of the error message.


    EDIT: Add links to release notes.

    That saved my day. Thanks.

Sign In or Register to comment.