The file "obj\Debug\android\bin\packaged_resources" does not exist

I just installed Xamarin in Visual studio and i have installed all files from the Android SDK library as well as done any updates to visual studio.
When I create a new project and try to run it I get the error: The file "obj\Debug\android\bin\packaged_resources" does not exist. After googling people said that their may be a resource with an incorrect name but it is a new project so all files are still untouched. Ive updated all nuget packages and still get the error.

Is there anything I need to install or update that I may have missed?

Best Answer

Answers

  • PawelTktiPawelTkti USMember

    I have the same problem, after install the newest version Xamarin.Forms v2.2.0.4-pre1.

    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1691,3): error MSB3375: The file "obj\Debug\android\bin\packaged_resources" does not exist.
    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1665,3): error MSB6006: "aapt.exe" exited with code -1073741819.

  • This is the build output

  • @PawelTkti thanks that worked :/ I dont know how I didnt think of that

  • SWDVLPRSWDVLPR USMember
  • TrucNguyenTrucNguyen USMember

    I have the problem too. Anybody help?

  • MarlonDiasMarlonDias USMember

    Same annoying problem with me!
    But I found a solution: read carefully this article:
    https://gxconsultancy.wordpress.com/2016/04/04/to-use-xamarin-or-not-to-us-xamarin/

  • LuisAngel.4535LuisAngel.4535 USMember
    edited July 2016

    Solo se tiene que eliminar la revición 24 de Android SDK Build-tools del SDK de android

  • To everyone who still has this problem. Uninstall the latest build tools and any other ones that you dont need. I unistalled 24 rc1 & 24 rc2 then it worked so just play around with uninstalling stuff until it does.

  • BrownShomariBrownShomari USMember

    For me, I found that I had image name with a "-" (hyphen) in my drawable folder. After renaming it (actually, I deleted it, since I did not need it), the above-mentioned error disappeared.

  • BalakrishnanSBalakrishnanS USMember ✭✭

    For me also, I found that I had image name with a "-" (hyphen) in my drawable folder. After renaming it , the above-mentioned error disappeared.

  • Aditya.KumarAditya.Kumar USUniversity ✭✭

    The way i fixed this:
    Check the image names in the drawable folder, and remove symbols like "@ or -".

  • FilipHristovskiFilipHristovski USMember

    The same thing happened to me i had a few files with "@". I renamed the files and everything worked fine.

  • PiotrZielinskiPiotrZielinski USMember

    For me, helped to dive into build log in output window (verbose mode). It said that I have a typo in some element's id definition in axml file.
    It was:
    android:id="+@id/titleTextView",
    and should be android:id="@+id/titleTextView".

  • Anna_nAnna_n ILMember

    I got this error when used the image and have not add it to the resources

Sign In or Register to comment.