Clipboard: copy/paste problem

alberto.palberto.p ITMember ✭✭

Hi,
I have problem with copy and paste from clipboard.
I get this error from Xamarin Studio 4.0.8:

System.ArgumentException: Lunghezza della matrice di origine insufficiente. Controllare srcIndex, la lunghezza e i limiti inferiori della matrice.
in System.Array.Copy(Array sourceArray, Int32 sourceIndex, Array destinationArray, Int32 destinationIndex, Int32 length, Boolean reliable)
in Mono.TextEditor.ClipboardActions.<>c__DisplayClass4.b__0(Clipboard clp, SelectionData selectionData)
in GtkSharp.ClipboardReceivedFuncWrapper.NativeCallback(IntPtr clipboard, IntPtr selection_data, IntPtr data)

Posts

  • rogiheerogihee NLMember ✭✭✭

    With me, the copy paste is not working from Chrome nor NotePad++ on Windows. I"m using 4.0.10, build 7.

    This is really annoying!

  • mhutchmhutch USMember, Xamarin Team Xamurai

    This issue should be fixed in the next release. Please file a bug if it still happens.

  • BurridgeBurridge USMember

    Not fixed. Still happens to me and a coworker.

  • BurridgeBurridge USMember

    I'm not filing a bug tho. Lost enough time at work as-is having to retype code.

  • BurridgeBurridge USMember

    Still happening in 4.2 one year later. Come on bros. :/

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @MikeKrueger: ping

  • MikeKrgerMikeKrger DEXamarin Team, Beta Xamurai

    Windows clipboard is broken in gtk - we've a bug open about that.

  • BurridgeBurridge USMember

    I'm referring to Xamarin Studio. Clipboard is not working. Is Xamarin Studio running on gtk?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Yes, Xamarin Studio uses GTK.

  • masonmason USMember

    Still an issue.

  • GerardMaternaGerardMaterna BEMember ✭✭

    Still an issue for me too (XS 5.1) but I found out something that may help debugging the issue (or work around for small texts)
    1) I copy some text from outside XS (chrome for example)
    2) I try to paste it in a .cs file but nothing happens
    3) I open the "Immediate" window
    4) If I paste, the text is pasted
    5) I do CTRL-C from this text in the "Immediate" window
    6) Then I am able to paste it in the .cs file

    It is still very annoying and is only for small text.

  • Still a issue, I am a newbie, using the latest on windows

  • SergeyKnyshSergeyKnysh USMember

    Guys, I had the same issue. May be this will help for some of you.
    Xamarin Studio, Win8.1
    I have two keybords (input methods) installed on my machine.
    Ctrl+C, Ctrl+V doesn't work when I start Xamarin Studio when Russian Input method is selected.
    If I switch to English and restart Xamarin. Copy/Paste works.
    Hope that helps.

  • TimoKeller.9444TimoKeller.9444 DEMember ✭✭

    Still a problem, so please...

  • ShawnLee.4281ShawnLee.4281 USMember ✭✭

    Unresolved problem after 2 years later.

  • JeffHaynesJeffHaynes USMember

    Still a problem, although about what I've come to expect from Xamarin.

  • robotoroboto USMember

    Restarting Xamarin temporarily fixes this issue, but it crops up again eventually. For me it tends to happen pretty frequently.

  • foxnetfoxnet INMember

    Xamarin Studio 5.9.4 has issue with copying & pasting from chrome

  • OmarCornejoOmarCornejo MXMember

    Seriously no one will attend this bug? Is there a repository we indie subscribers can access to evaluate and correct that kind of bugs?

  • OmarCornejoOmarCornejo MXMember

    Whenever I can't paste into Xamarin Studio, copy something inside de editor to clipboard, return to the window with the content I want to copy / paste and copy it again. Then the paste function works again in XS. It's an annoying workaround, but it works while we have a definitive solution.

  • vnevvnev USMember

    Big up to @OmarCornejo. That workaround worked here.
    Tks

  • Chris_LamontChris_Lamont USUniversity ✭✭

    Starting to have this problem. Should it be fixed by now?

  • SamiKuhmonenSamiKuhmonen USMember

    @Chris_Lamont said:
    Starting to have this problem. Should it be fixed by now?

    Nope, still not fixed. And never will, since XS is of no importance anymore. Hope they will fix the issues with Visual Studio though...

  • JohanMulderJohanMulder USMember ✭✭

    This is still an issue. I can't copy the code from notepad and paste the result in Xamarin Studio.

  • JohanMulderJohanMulder USMember ✭✭

    This is definitely still a bug - to copy from notepad first goto XS then do a dummy copy in XS. After this then go and copy from notepad to XS.

Sign In or Register to comment.