Can't startup Xamarin Studio iOS after updating failed.

DivinerDiviner HKMember
edited July 2013 in Visual Studio

Hi all,

Today I start Xamarin Studio and it prompts me that update. I go on but it prompt me that the update is failed in few seconds.

So I close the error dialog, then Xamarin Studio can't start anymore.

And then I download the new install package and try to install again, result in same, the installation progress can't start.

XamarinInstaller.dmg version:
Install Xamarin 3.0.0
Last modify date: 2013-07-25 08:00:22am

(I can see this screen)

(But it doesn't shows following screen after double-click on the button, and the install program is dropped.)

I have uninstall the existing Xamarin Studio by drop its icon (from both Icon Bar and Application window). But no luck, I still can't install it. (Even I manually deleted the leaving XamarinStudio-4.0 folder and Xamarin folder)

What can I do now?

(My Mac OS is most updated for my Macbook Pro in Lion 10.7.5 , I don't know the version of Xamarin Studio because I can't start it for checking)

Thank you very much.

--
Diviner.

Posts

  • JUCHIEHHUANGJUCHIEHHUANG TWMember

    The same to me, help!!

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    You can get Xamarin Studio from http://monodevelop.com/Download without the need for the universal installer (which is what you are trying to use).

    Also, make sure that you have Mono 3.2.0:

    http://www.go-mono.com/mono-downloads/download.html

    I'd suggest downloading the MDK.

    Hope that helps.

  • MarekHabersack.8861MarekHabersack.8861 PLXamarin Team Xamurai

    @diviner, @dearplato - could you provide installation logs from ~/Library/Logs/XamarinInstaller/Universal/ ? Please attach the log that was created during the failed installation, thanks.

  • FangHuaiAnFangHuaiAn TWMember
    edited July 2013

    I update four components automated failed too, there's log recorded in
    ~/Library/Logs/XamarinStudio-4.0/Updater.log

    But I can install Mono 3.2.0 manually, I can compile simple file with 3.2.0.
    Then I download "XamarinStudio-4.0.10.dmg", but the application can't startup.

    2013-07-30 08:15:46.160 Xamarin Update[916:707] Reading index file
    2013-07-30 08:15:46.163 Xamarin Update[916:707] Loaded 4 updates from index file
    2013-07-30 08:15:46.164 Xamarin Update[916:707] Requesting root authorization
    2013-07-30 08:15:53.306 Xamarin Update[916:707] Acquired root authorization
    2013-07-30 08:15:53.306 Xamarin Update[916:707] Updates require restart, terminating MonoDevelop and related apps
    2013-07-30 08:15:53.340 Xamarin Update[916:7127] Installing update 1 of 4
    2013-07-30 08:15:53.340 Xamarin Update[916:7127] Installing package '/Users/fangha/Library/Caches/XamarinStudio-4.0/TempDownload/964ebddd-1ffe-47e7-8128-5ce17ffffb05-302000000.pkg'
    2013-07-30 08:15:53.340 Xamarin Update[916:7127] /usr/sbin/installer -pkg '/Users/fangha/Library/Caches/XamarinStudio-4.0/TempDownload/964ebddd-1ffe-47e7-8128-5ce17ffffb05-302000000.pkg' -target / -verboseR
    2013-07-30 08:15:53.341 Xamarin Update[916:7127] Requesting root authorization
    2013-07-30 08:15:53.343 Xamarin Update[916:7127] Acquired root authorization
    2013-07-30 08:16:24.495 Xamarin Update[916:7127] ERROR: installer did not indicate successful completion
    2013-07-30 08:16:24.495 Xamarin Update[916:7127] Update failed to install
    2013-07-30 08:16:24.496 Xamarin Update[916:7127] Skipping remaining 3 updates
    2013-07-30 08:16:24.496 Xamarin Update[916:707] Error Domain=xamarin.updater Code=-1 "Package failed to install" UserInfo=0x60000026c340 {NSLocalizedDescription=Package failed to install}
    2013-07-30 08:16:37.157 Xamarin Update[916:707] Restarting MonoDevelop

    Environment:
    Hardware : MacBook Air 11" 2011 mid
    OS : OS X 10.9 (13A524d)
    Xcode 4: Version 4.6.3 (4H1503)
    Xcode 5: Version 5.0 (5A11344j)

  • mhutchmhutch USMember, Xamarin Team Xamurai

    This was a regression that caused Mono to crash on certain locales. It has been fixed in Mono 3.2.1_1.

  • FangHuaiAnFangHuaiAn TWMember

    Thanks, @mhutch
    I change to beta channel now.
    It's works.

  • DivinerDiviner HKMember

    Mono 3.2.1_1 works for me also. ^_^

Sign In or Register to comment.