Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Visual Studio not able to show iOS simulator drop down

Hi everyone,

I am working on a Xamarin Forms project in Visual Studio 2015. When I connect to a Mac agent to run my app in a simulator, I get
the error pasted below and the drop-down list of iOS simulators is empty. The problem suddenly appeared in the past week, so I was thinking that it has something to do with me updating the system/Xcode on my Mac machine. Unfortunately it does not look like other people experience the same problem. Do you have any idea of what the issue might be?

Regards,
Marcin

2016-03-31 10:09:42.927 mtouch[2935:214560] -[SimDevice pairedDevice]: unrecognized selector sent to instance 0x7fd9c3516650

2016-03-31 10:09:42.927 mtouch[2935:214560] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SimDevice 
pairedDevice]: unrecognized selector sent to instance 0x7fd9c3516650'
*** First throw call stack:
(
0   CoreFoundation                      0x00007fff930754f2 __exceptionPreprocess + 178
1   libobjc.A.dylib                     0x00007fff98d21f7e objc_exception_throw + 48
2   CoreFoundation                      0x00007fff930df1ad -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
3   CoreFoundation                      0x00007fff92fe5571 ___forwarding___ + 1009
4   CoreFoundation                      0x00007fff92fe50f8 _CF_forwarding_prep_0 + 120
5   ???                                 0x0000000112ac3096 0x0 + 4608241814
6   ???                                 0x000000010e497c83 0x0 + 4534664323
7   ???                                 0x000000010cfe5eca 0x0 + 4512964298
8   ???                                 0x000000010cff1543 0x0 + 4513011011
9   mtouch                              0x000000010b0ff502 get_mtouch_full_path + 1803314
10  mtouch                              0x000000010b20d087 get_mtouch_full_path + 2908087
11  mtouch                              0x000000010b215f2a get_mtouch_full_path + 2944602
12  mtouch                              0x000000010b215c51 get_mtouch_full_path + 2943873
13  mtouch                              0x000000010afb0297 get_mtouch_full_path + 430535
14  mtouch                              0x000000010afb3d10 get_mtouch_full_path + 445504
15  mtouch                              0x000000010afb2817 get_mtouch_full_path + 440135
16  mtouch                              0x000000010af4733a get_mtouch_full_path + 618
17  mtouch                              0x000000010af466e4 mtouch + 5860
)

libc++abi.dylib: terminating with uncaught exception of type NSException
Stacktrace:

at <unknown> <0xffffffff>

at (wrapper managed-to-native) MonoMac.ObjCRuntime.Messaging.IntPtr_objc_msgSend (intptr,intptr) <0xffffffff>
at Xamarin.Hosting.Bindings.SimDevice.get_PairedDevice () <0x0003f>

at MonoTouch.Simulator.SimController.ListSimulators (string) <0x00ff8>
at MTouch.Main2 (string[]) <0x069b2>
at MTouch.Main (string[]) <0x00069>
at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:


0   mtouch                              0x000000010b0ec43e get_mtouch_full_path + 1725294
1   mtouch                              0x000000010b0f7b0e get_mtouch_full_path + 1772094
2   libsystem_platform.dylib            0x00007fff86b4952a _sigtramp + 26
3   ???                                 0x00000000889e86c9 0x0 + 2292090569
4   libsystem_c.dylib                   0x00007fff889d76e7 abort + 129
5   libc++abi.dylib                     0x00007fff93b9cf81 __cxa_bad_cast + 0
6   libc++abi.dylib                     0x00007fff93bc2a47 _ZL26default_unexpected_handlerv + 0
7   libobjc.A.dylib                     0x00007fff98d246ae _ZL15_objc_terminatev + 103
8   libc++abi.dylib                     0x00007fff93bc019e _ZSt11__terminatePFvvE + 8
9   libc++abi.dylib                     0x00007fff93bbfc12 _ZN10__cxxabiv1L22exception_cleanup_funcE19_Unwind_Reason_CodeP17_Unwind_Exception + 0
10  libobjc.A.dylib                     0x00007fff98d2208c objc_exception_throw + 318
11  CoreFoundation                      0x00007fff930df1ad -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
12  CoreFoundation                      0x00007fff92fe5571 ___forwarding___ + 1009
13  CoreFoundation                      0x00007fff92fe50f8 _CF_forwarding_prep_0 + 120
14  ???                                 0x0000000112ac3096 0x0 + 4608241814
15  ???                                 0x000000010e497c83 0x0 + 4534664323
16  ???                                 0x000000010cfe5eca 0x0 + 4512964298
17  ???                                 0x000000010cff1543 0x0 + 4513011011
18  mtouch                              0x000000010b0ff502 get_mtouch_full_path + 1803314
19  mtouch                              0x000000010b20d087 get_mtouch_full_path + 2908087
20  mtouch                              0x000000010b215f2a get_mtouch_full_path + 2944602

21  mtouch                              0x000000010b215c51 get_mtouch_full_path + 2943873
22  mtouch                              0x000000010afb0297 get_mtouch_full_path + 430535
23  mtouch                              0x000000010afb3d10 get_mtouch_full_path + 445504
24  mtouch                              0x000000010afb2817 get_mtouch_full_path + 440135
25  mtouch                              0x000000010af4733a get_mtouch_full_path + 618
26  mtouch                              0x000000010af466e4 mtouch + 5860

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Best Answer

Answers

  • NigelPalmerNigelPalmer USMember

    I am getting exactly the same problem as you. Everything was working fine when I left work yesterday and when I returned this morning I have been unable to see any simulators in my drop down list. If I plug in an iPad then that does appear but the simulators remain missing. My error log is almost identical to yours. I have rebooted both machines several times and upgraded xamarin in visual studio. Nothing helps. Does anyone have a solution to this? This has cost me half a days worth of work already.

  • MarcinKuptelMarcinKuptel USMember

    Updating Xamarin on my Mac did the trick! Thanks Nigel.

Sign In or Register to comment.