Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

I have just upgrade to Business Plan, but debugging is not working on Visual Studio 2012

I have just upgrade to Business Plan, but debugging is not working on Visual Studio 2012, but working fine on Xamarin Stuido.

Answers

  • JimBennettJimBennett GBXamarin Team, Insider, University, Developer Group Leader ✭✭✭✭

    What debugging? If it's Android then are you on the latest version? An issue with android debugging was fixed in the 146 build so should be available in the latest stable release.

  • ChrisChanChrisChan MYMember

    the problem is i can deploy and debug to my phone via Xamarin Studio but not in Visual Studio 2012.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @ChrisChan It appears your problem statement is not clear. As I understand,

    1. You use VS2012 for your development.
    2. You are able to debug when you deploy your Xamarin.Android app to your Android phone from VS2012.
    3. You are **N-O-T** able to debug when you deploy it to the Android Emulator for Visual Studio. That is the problem you have.

    If I am correct in understanding your problem, then I can say the probability of resolving your issue is very small, because even I have that issue and not finding any viable solution that works for me, even with VS2015.

    @JimBennett You mentioned:

    An issue with android debugging was fixed in the 146 build so should be available in the latest stable release.

    What's that "146 build"? Can you give full name and version number?

  • JimBennettJimBennett GBXamarin Team, Insider, University, Developer Group Leader ✭✭✭✭

    It's available here:

    https://bugzilla.xamarin.com/show_bug.cgi?id=39433#c8

    Don't think these changes are in the official stable release yet as some people are still seeing them in stable which is 147

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    Thanks @JimBennett . I have Xamarin 4.0.1.147 and I used to get that exception earlier but not now.

    However, for me, VS Emulator for Android doesn't throw any exception. The app just crashes 90% of the time. No output message is given.

Sign In or Register to comment.